help please! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-16-2008
3.0Backfire's Avatar
Member
Thread Starter
 
Join Date: Apr 2008
Location: So-Cal
Posts: 357
help please!

Okay so im tryin to sell my 97' F150 4.6L and today i have some people coming by to look at it, so i thought i would clean up the engine a little bit with some of that "Engine Degreaser" and i sprayed it on and waited then washed it off, now my truck idles and runs like crap! it seems to want to hesitate and want to die on me at an idle, and it seems to have a loss of power when im driving it, what could it be and what should i do before the people come today?!
Reply With Quote
  #2  
Old 07-16-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Check to see if you got water in the pug wires between the wire and the plug. Also push in the wires at the coil and plugs. Then check for any vacuum hoses that are not connected to anything.
Reply With Quote
  #3  
Old 07-16-2008
leadfoot's Avatar
Member
 
Join Date: Oct 2007
Location: MA
Posts: 894
Yeah, check and dry off your coil pack, leave the hood open to dry in the sun.
Reply With Quote
  #4  
Old 07-16-2008
3.0Backfire's Avatar
Member
Thread Starter
 
Join Date: Apr 2008
Location: So-Cal
Posts: 357
If i just let it sit on my street and not start it up for a couple hours, do you think it will completely dry and work right?
Reply With Quote
  #5  
Old 07-17-2008
Shaklakan's Avatar
Member
 
Join Date: Jan 2008
Location: La Habra CA
Posts: 1,100
dude that blows!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
PLEASE PLEASE PLEASE.... annguyen1981 General Ford Ranger Discussion 13 12-05-2013 03:35 PM
please tell me where my PCV is, Please (did search) uplandhunter General Technical & Electrical 16 02-07-2011 09:34 AM
E-Brake help. Please help me out. Need to get done asap. rybread5520 General Technical & Electrical 2 01-02-2009 10:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.