Odometer and Speedo stuck- help asap...!? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-05-2006
Member
Thread Starter
 
Join Date: Oct 2006
Location: Northeast, PA
Posts: 32
Odometer and Speedo stuck- help asap...!?

Was getting a new starter/alarm system put in- have to go back tomorrow 'cause he didn't have a part....sucks....anyway, when I started out for home, I noticed the following:
-odometer stuck, not moving
-speedometer stuck, not moving
-seatbelt indicator light keeps flashing on (as if to say there was somebody not wearing them, but my daughter and I had both of them on)....
I gotta assume this was done while it was in getting worked on. I have to go back anyway, so I called the guy. When I told him the gauges were stuck, he said he didn't think he did anything to them. I said YEP, YOU DID...obviously. Everything worked fine when I took it in (I keep mileage for one of the hospitals I travel to for work, so I know that for a fact)...
He had to mess with the wiring a bit since the old starter was burnt out.
Can anybody help me out with what might be going on? I want to have a bit of knowledge about it for tomorrow when I take it back in. I'm assuming something isn't plugged in right and I WILL make sure that it's done right before I leave tomorrow.
Thanks!
Reply With Quote
  #2  
Old 12-05-2006
HighRollerII's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Jun 2004
Location: Charleston, SC
Posts: 10,066
heck if i know but id let that place figure that out..lol
Reply With Quote
  #3  
Old 12-05-2006
FMD's Avatar
FMD FMD is offline
Member
iTrader: (1)
 
Join Date: Aug 2005
Location: Amherst NY
Posts: 3,811
think of it this way, free mileage!
Reply With Quote
  #4  
Old 12-06-2006
Member
Thread Starter
 
Join Date: Oct 2006
Location: Northeast, PA
Posts: 32
Anybody have any serious suggestions for this? Just in case the guy doing it isn't sure what's up, maybe I can check it out when he's working with it?
Reply With Quote
  #5  
Old 12-06-2006
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,833
The speedometer/odo is driven by an electric motor so it would be easy for an unplugged connector to cause that. The wiring for the speedo/odo and the seat belt indicator are in a common connector on the back of the instrument cluster. Also check fuses 11 and 26 in the dash box.

Last edited by V8 Level II; 12-06-2006 at 06:59 AM.
Reply With Quote
  #6  
Old 12-06-2006
Member
Thread Starter
 
Join Date: Oct 2006
Location: Northeast, PA
Posts: 32
Thanks!
Everything seems to be working ok now!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Speedo Odometer question cheetahman General Technical & Electrical 2 09-12-2014 10:54 AM
New gears and 35s... Speedo and Odometer way off!!!! MugenCRX04 Drivetrain Tech 31 09-15-2009 11:40 PM
wipers, speedo, and odometer dont work littlered General Technical & Electrical 29 09-08-2009 11:03 PM
Speedo/Odometer Recalibration jamesxEDGE General Technical & Electrical 3 12-05-2007 07:36 PM
Help Help Help Gear Indicator Stuck BananaEdge General Technical & Electrical 5 06-16-2005 12:05 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:51 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.