oil pressure/engine noise - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-27-2011
Member
Thread Starter
 
Join Date: Feb 2011
Location: Great Falls VA
Posts: 2
oil pressure/engine noise

I have a 1999 Ford Ranger (two-wheel drive, 138,000 miles). Twice in the past year I have had this happen: I notice truck is running very loudly/rough, and notice the oil pressure gauge shows no pressure. The first time, I pulled over, had it towed. At the service station they started it up, gauge was normal. I took it to the dealership, they replaced the sending unit, could not explain why it might be running rough. Today: same thing: gauges normal when I left home, and hour later I notice it running rough, gauge says no pressure. Pull over, turn it off, restart: still no pressure. Turn it off and let it sit 15 - 20 minutes, start it up: gauge is normal, runs smoothly.

What do I have them check next?
Reply With Quote
  #2  
Old 02-27-2011
04XLTFX4's Avatar
Member
 
Join Date: Jan 2011
Location: Huntingdon,Pa
Posts: 191
You might have sludge or something in the pan getting picked up by the pick up screen blocking it killing oil pressure. You shut it down it falls off you have oil pressure again. Happens to 4.0 sohc with all the plastics from broken cam tentioners in the pan.
Reply With Quote
  #3  
Old 02-28-2011
Member
Thread Starter
 
Join Date: Feb 2011
Location: Great Falls VA
Posts: 2
"You might have sludge or something in the pan getting picked up by the pick up screen blocking it killing oil pressure. You shut it down it falls off you have oil pressure again. Happens to 4.0 sohc with all the plastics from broken cam tentioners in the pan. "

Is this something an oil-change would fix?
Reply With Quote
  #4  
Old 02-28-2011
StrangerRanger's Avatar
Member
 
Join Date: Jan 2009
Location: The 253
Posts: 756
Mine did that when I had the PVC tube bent and there was a kink in it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'03 4.0 Engine noise, barely running, no oil pressure...help? spat12 4.0L OHV & SOHC V6 Tech 3 07-30-2015 11:56 PM
Water & oil temp, oil pressure gauges ad74710 General Technical & Electrical 1 05-23-2014 05:59 PM
Oil Pressure Port Location for adding an aftermarket oil pressure sending unit FRXLT 2.9L & 3.0L V6 Tech 29 01-31-2012 11:05 AM
Ticking noise and low oil pressure issjoe 2.9L & 3.0L V6 Tech 3 12-26-2010 08:17 AM
Oil Pressure Light ( Low Oil light ) ?? justinkeoughan 4.0L OHV & SOHC V6 Tech 9 03-25-2010 06:47 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:48 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.