Squeak Help!!!! 1998 extra cab - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-20-2010
t5cents's Avatar
Member
Thread Starter
iTrader: (6)
 
Join Date: Nov 2008
Location: Eureka, CA
Posts: 1,521
Squeak Help!!!! 1998 extra cab

ok so i have this squeak that is annoying as hell. i know u guys cant hear it so u cant help diagnose it.,....but maybe someone has had the same squeak and i can get some ideas. ok so I THINK its some where in the cab. either that or right near it out side. it is somewhere in in the back and it sounds like its driver side. it ONLY does it when i drive. i cant move any thing or shake the truck in any way to make it do it. but as soon as i start driving it does it. it does it randomly when im just driving straight but does it when i hit bumps, turn form side to side, or give it gas and let off to kinda get a jerking thing going. it also stops when i hit the brakes. any ideas or things to check? thanks
Reply With Quote
  #2  
Old 04-20-2010
02_xlt's Avatar
Member
 
Join Date: Mar 2010
Location: Mauriceville, TX
Posts: 134
Quote:
Originally Posted by t5cents View Post
ok so i have this squeak that is annoying as hell. i know u guys cant hear it so u cant help diagnose it.,....but maybe someone has had the same squeak and i can get some ideas. ok so I THINK its some where in the cab. either that or right near it out side. it is somewhere in in the back and it sounds like its driver side. it ONLY does it when i drive. i cant move any thing or shake the truck in any way to make it do it. but as soon as i start driving it does it. it does it randomly when im just driving straight but does it when i hit bumps, turn form side to side, or give it gas and let off to kinda get a jerking thing going. it also stops when i hit the brakes. any ideas or things to check? thanks
my 02 is doin the same thing and its driving me crazy. mine also does it if i slam my door.
Reply With Quote
  #3  
Old 04-20-2010
Member
 
Join Date: Mar 2010
Location: Tiverton, RI
Posts: 40
mine does the same thing. I think it might be the rubber things that are placed between the cab/bed and frame. I think they might be going or lose or something. That was my guess. I haven't had the time to inspect them thoroughly. I might this weekend though, I have to replace my shackles.
Reply With Quote
  #4  
Old 04-20-2010
02_xlt's Avatar
Member
 
Join Date: Mar 2010
Location: Mauriceville, TX
Posts: 134
Quote:
Originally Posted by RPurdyJ View Post
mine does the same thing. I think it might be the rubber things that are placed between the cab/bed and frame. I think they might be going or lose or something. That was my guess. I haven't had the time to inspect them thoroughly. I might this weekend though, I have to replace my shackles.
if i t were the body mount bushings, wouldnt it do it when you shake the cab?
Reply With Quote
  #5  
Old 04-20-2010
d0sitmatr's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2010
Location: SFL
Posts: 706
Quote:
Originally Posted by 02_xlt View Post
if i t were the body mount bushings, wouldnt it do it when you shake the cab?
not necessarily.
the weight of the cab itself plus your added weight, coupled with the motion from the road is going to be more than you can ever accomplish by yourself. plus, the squeeking (if the mount bushings) would be caused by the weight shifting down most likely, not side to side.

I cant offer any other help though as my truck doesnt do this. although I do think I need to replace mine, its not because they are going bad, but I think they are just non-existent.
Reply With Quote
  #6  
Old 04-20-2010
t5cents's Avatar
Member
Thread Starter
iTrader: (6)
 
Join Date: Nov 2008
Location: Eureka, CA
Posts: 1,521
ya mine does it too if i slam my door...its so annoying...and ya i cant get it to make it when i shake the cab either.....
Reply With Quote
  #7  
Old 04-20-2010
Ranger_Guy15's Avatar
Member
 
Join Date: Apr 2007
Location: MN
Posts: 2,827
My truck squeaks too, but it seems to squeak at a faster pace when im driving, and it slows as I slow down. I have no idea what it could be.
Reply With Quote
  #8  
Old 04-20-2010
t5cents's Avatar
Member
Thread Starter
iTrader: (6)
 
Join Date: Nov 2008
Location: Eureka, CA
Posts: 1,521
also i cant do any thing to make it stop except to hit the brakes. i cant put pressure on anything to make it stop...im lost
Reply With Quote
  #9  
Old 04-23-2010
t5cents's Avatar
Member
Thread Starter
iTrader: (6)
 
Join Date: Nov 2008
Location: Eureka, CA
Posts: 1,521
ok well iv done some more narrowing down...it stops when ever im not driving straight...stops when i turn, accelerate and when i slow down. also if when im sitting in the driver seat and i push on the passenger side headrest and kinda pry the seats apart it stops...so im pretty sure it has something to do with the seats...i think
Reply With Quote
  #10  
Old 04-23-2010
offroadn_redneck's Avatar
Member
 
Join Date: Feb 2009
Location: San Antonio, TX
Posts: 776
Strange. The only squeaks i get out of mine is when i dont have the back doors shut all the way.
Reply With Quote
  #11  
Old 04-23-2010
Toms994x4's Avatar
Member
iTrader: (4)
 
Join Date: Jul 2009
Location: Sanford, NC
Posts: 1,300
After running my TSL's I have noticed quite a few squeaks/vibrations/noises. Turn the radio up...
Reply With Quote
  #12  
Old 04-23-2010
t5cents's Avatar
Member
Thread Starter
iTrader: (6)
 
Join Date: Nov 2008
Location: Eureka, CA
Posts: 1,521
ya i deffinatly had a bunch more noises with my tsl's on...but this one is really bad. it is like really loud. and i can hear it over my radio..and it is pretty much constant....lol
Reply With Quote
  #13  
Old 04-23-2010
Toms994x4's Avatar
Member
iTrader: (4)
 
Join Date: Jul 2009
Location: Sanford, NC
Posts: 1,300
What I mean is, after running the TSL's and putting my AT's back on it seemed to have loosened some **** up on my truck. Now it squeaks from running them.
Reply With Quote
  #14  
Old 04-24-2010
t5cents's Avatar
Member
Thread Starter
iTrader: (6)
 
Join Date: Nov 2008
Location: Eureka, CA
Posts: 1,521
well today after tearing out the entire interior to try and find the squeak i decided that it is out side the cab....i couldnt pin point it so i just sprayed wd40 around where it was coming from......and its gone!....so at least now i know what to do if it comes back....
Reply With Quote
  #15  
Old 04-24-2010
Toms994x4's Avatar
Member
iTrader: (4)
 
Join Date: Jul 2009
Location: Sanford, NC
Posts: 1,300
Where did you spray? That will narrow it down.
Reply With Quote
  #16  
Old 04-24-2010
t5cents's Avatar
Member
Thread Starter
iTrader: (6)
 
Join Date: Nov 2008
Location: Eureka, CA
Posts: 1,521
just the general area under the rear portion of the cab...lol
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
extra cab false deck equipment rack grunt98444 Audio & Video Tech 0 08-15-2013 05:02 AM
1997 Ford Extra cab - $4000 newschoolpickup Ranger Based Vehicles 1 01-21-2012 02:21 AM
1998 Ford Ranger Extra Cab in SF Bay Area California Dropped98 Ranger Based Vehicles 0 09-06-2009 01:59 AM
1998 Ranger Extra Cab Dropped98 Ranger Based Vehicles 2 09-04-2009 12:00 PM
Squeak squeak--help 0RangerEdge2 Suspension Tech 2 09-13-2008 12:06 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:00 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.