Truck Died Now Wont Start! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-10-2006
Roach2004's Avatar
RF Veteran
Thread Starter
iTrader: (3)
 
Join Date: May 2005
Location: Houston, TX
Posts: 8,320
Truck Died Now Wont Start!

Last night I was on my way home and my oil light came on then about a minute later my truck just died and would not turn over at all it just goes click. Well I checked my oil yesterday morning and after it happend I have plenty of oil but its really dark and I need to change it anyone have any ideas? Its not throwing any codes anything.
Reply With Quote
  #2  
Old 06-10-2006
KARPE's Avatar
Member
 
Join Date: Apr 2005
Location: Valrico, Fl 33594
Posts: 4,748
all I can say is Uh Oh. thank god there is still Oil in there but being really dark I couldn't tell you the extent of possible damage
Reply With Quote
  #3  
Old 06-10-2006
Bigwill41's Avatar
Member
 
Join Date: Jun 2004
Location: Navasota, Texas
Posts: 4,659
Did you change your Oil lately..
Reply With Quote
  #4  
Old 06-10-2006
jtslmn720's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Location: Kent State, Kent Ohio
Posts: 7,367
drain all your oil and change it, its probably so old and crappy that your engine just seized on you because its so thick now...
Reply With Quote
  #5  
Old 06-10-2006
ranger024x4's Avatar
RF Veteran
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
Quote:
Originally Posted by Roach2004
Last night I was on my way home and my oil light came on then about a minute later my truck just died and would not turn over at all it just goes click.
first mistake... if the oil light comes on.. always shut off the engine.

it sounds like you seized ur engine
Reply With Quote
  #6  
Old 06-10-2006
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Posts: 17,221
how long did u go without oil roach? Don't you deliver so high miles?

Aaron
Reply With Quote
  #7  
Old 06-10-2006
Member
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
its seized..lol just happened to us a month ago on the 05 5.4L
Reply With Quote
  #8  
Old 06-10-2006
bwester04's Avatar
Member
 
Join Date: Mar 2006
Location: Round Rock, Tx
Posts: 2,641
damn dude.. sorry to hear that it might be seized, i guess thats a reminder to us all to keep up on the oil changes and such..
Reply With Quote
  #9  
Old 06-10-2006
2003Ranger's Avatar
Member
 
Join Date: Feb 2005
Location: South Lyon, Michigan
Posts: 657
Time for a 5.0 Liter !
Reply With Quote
  #10  
Old 06-10-2006
jorlee's Avatar
Member
 
Join Date: Jul 2005
Location: SW North Dakota
Posts: 119
Have you tried turning it over manually?
Can you give us the time frame on the oil since last change?

Don't you still have warranty?
Reply With Quote
  #11  
Old 06-10-2006
Member
 
Join Date: Jun 2004
Location: Fayetteville, NC
Posts: 1,966
5.0 won't happen he drives a 04 and lives in TX.

I think he passed the warranty a long time ago.

Change the oil and make sure there isn't anything in it.
Reply With Quote
  #12  
Old 06-10-2006
FireRanger's Avatar  
Join Date: May 2004
Location: CT
Posts: 0
Before we just assume his engine is toast, have you tried jump starting it yet?
Reply With Quote
  #13  
Old 06-10-2006
speed_racer_801's Avatar
Member
 
Join Date: Feb 2006
Location: Ogden, Utah
Posts: 124
A while ago when I was towing my RX7 I stalled my truck and it wouldn't start and it seemed like it was sized but it turned out that I fried the ignition wire that goes to the starter, you might want to check that, it was a $20.00 fix at Autozone.
Reply With Quote
  #14  
Old 06-10-2006
HighRollerII's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Jun 2004
Location: Charleston, SC
Posts: 10,066
speakin of that i gotta change mine BAD...
Reply With Quote
  #15  
Old 06-10-2006
Roach2004's Avatar
RF Veteran
Thread Starter
iTrader: (3)
 
Join Date: May 2005
Location: Houston, TX
Posts: 8,320
Its only been about 4,000 miles since my last change. I am going to try and jump start it tommorow after I change the oil. I heard somewhere that on newer model vehicles it will shut off before somthing really messes up. I would have stopped right when it came on but I was on a long 2 lane road with no where to stop. If it is seized I am getting a 4.0!
Reply With Quote
  #16  
Old 06-10-2006
Bigwill41's Avatar
Member
 
Join Date: Jun 2004
Location: Navasota, Texas
Posts: 4,659
Quote:
Originally Posted by Roach2004
If it is seized I am getting a 4.0!
You Bet.

I hope it did.
Reply With Quote
  #17  
Old 06-11-2006
quest51210
Unregistered User
 
Posts: n/a
Quote:
Originally Posted by Pinecone
5.0 won't happen he drives a 04 and lives in TX.
what does that mean? imma do a 5.0 swap asap. TX dont bother you about this stuff.
Reply With Quote
  #18  
Old 06-11-2006
bwester04's Avatar
Member
 
Join Date: Mar 2006
Location: Round Rock, Tx
Posts: 2,641
he meant that since his is an '04 and the last year of the explorer 302 was in '01 that it might be tough to pass emissions..
Reply With Quote
  #19  
Old 06-11-2006
quest51210
Unregistered User
 
Posts: n/a
Quote:
Originally Posted by bwester04
he meant that since his is an '04 and the last year of the explorer 302 was in '01 that it might be tough to pass emissions..
emissions? man i got the hook up in galveston, houston, and san antonio on inspection. its $ 25, but beats the wait and hassle
Reply With Quote
  #20  
Old 06-11-2006
bwester04's Avatar
Member
 
Join Date: Mar 2006
Location: Round Rock, Tx
Posts: 2,641
$hit, hook me up! haha.. hell actually you know, my friends GT (the one that the a$$hole on 51st screwed over) needs an inspection but the CEL is on and it doesnt have cats..
Reply With Quote
  #21  
Old 06-12-2006
Sonic04Edge's Avatar
RF Veteran

iTrader: (6)
 
Join Date: Jun 2004
Location: Madison. AL
Posts: 5,715
My truck did the same thing. Ended up being a vacum hose fell off. Check ALL your hoses.
Reply With Quote
  #22  
Old 06-12-2006
ranger024x4's Avatar
RF Veteran
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
Quote:
Originally Posted by Sonic04Edge
My truck did the same thing. Ended up being a vacum hose fell off. Check ALL your hoses.
he already made a new thred.. the oil pump failed
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Incorrect jump start. Truck won't start now. Pilot General Technical & Electrical 3 10-27-2013 08:07 AM
1986 ranger died going down the road, wont start Jacobson86 General Technical & Electrical 4 08-15-2011 09:12 PM
Died and wont start! please help neville293 SOHC - 2.3L & 2.5L Lima Engines 2 06-30-2011 10:54 PM
97 died on highway and now wont start! jabs08zx6r SOHC - 2.3L & 2.5L Lima Engines 13 02-25-2011 08:58 AM
Help! Truck wont start now. -ETHEN- 2.9L & 3.0L V6 Tech 0 02-16-2011 08:26 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:06 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.