Your First Engine Light - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

View Poll Results: When did your first engine light come on?
0-20,000 miles 5 14.71%
20,001-40,000 miles 7 20.59%
40,001-60,000 miles 4 11.76%
60,001-80,000 miles 10 29.41%
80,001-100,000 miles 5 14.71%
100,000 miles plus 3 8.82%
Voters: 34. You may not vote on this poll

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 09-11-2006
jtslmn720's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Location: Kent State, Kent Ohio
Posts: 7,367
first one under my ownership was at 80k for dspe and the one i have now is 84k for the same problem just doubtfull if its the dpse again...
Reply With Quote
  #27  
Old 09-11-2006
bwester04's Avatar
Member
 
Join Date: Mar 2006
Location: Round Rock, Tx
Posts: 2,641
~35k miles for the Flex Fuel Sensor which was a $200 part then paid ford $150 in labor. But that was on the older style (98-00 i believe) flex fuel systems. Other than that, at ~78k just from the connector under the seat getting wet, but again, thats on pre-03 rangers and I have sealed that since.
Reply With Quote
  #28  
Old 09-11-2006
Trigger01's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Oct 2005
Location: Knoxville, TN
Posts: 18,788
Mine came on between 60-70k for a bad vapor seal in my gas cap.
Reply With Quote
  #29  
Old 09-11-2006
BRENSRANGER's Avatar
Member
 
Join Date: Jul 2006
Location: Minnesota
Posts: 1,308
160,000 and still no light hahaha
Reply With Quote
  #30  
Old 09-11-2006
mudranger96's Avatar
Member
 
Join Date: Oct 2005
Location: Lehigh Acres, FL
Posts: 2,549
140,000 o2 sensor
Reply With Quote
  #31  
Old 09-11-2006
MyTreadYourFace's Avatar
Member
 
Join Date: Nov 2005
Location: Grand Prairie, TX
Posts: 137
Probably doesn't count but I've got 180k on my Miata and still no light. :)
Reply With Quote
  #32  
Old 09-11-2006
karrbass4life's Avatar
Member
 
Join Date: Nov 2004
Location: Cincinnati, Ohio
Posts: 3,072
I bought my truck with the light on lmfao.

On since day one lmfao. I know whats wrong im just too poor to fix it.
Reply With Quote
  #33  
Old 09-11-2006
Bigwill41's Avatar
Member
 
Join Date: Jun 2004
Location: Navasota, Texas
Posts: 4,659
Mine came on at 6,000

I had about six check engine lights, i'm at 44,000 how

POS truck
Reply With Quote
  #34  
Old 09-11-2006
Member
 
Join Date: Nov 2005
Location: Aberdeen and Salisbury MD
Posts: 1,840
80,001-100,000 miles thats when mine went on. stupid egr valve went and something else. cost me $700 to fix
Reply With Quote
  #35  
Old 09-11-2006
l2en's Avatar
Member
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
Quote:
Originally Posted by mudranger96
140,000 o2 sensor
Damn yu've got 140k miles??? More power to ya bro! Gives me more faith in my 4.0 sohc.
Reply With Quote
  #36  
Old 09-11-2006
mudranger96's Avatar
Member
 
Join Date: Oct 2005
Location: Lehigh Acres, FL
Posts: 2,549
Quote:
Originally Posted by l2en
Damn yu've got 140k miles??? More power to ya bro! Gives me more faith in my 4.0 sohc.
No thats on my 3.0 96, my 2002 has 40,000 with no check engine light as of yet.
Reply With Quote
  #37  
Old 09-11-2006
anthony84_2004's Avatar
Member
 
Join Date: Apr 2006
Location: Jesup, Georgia
Posts: 760
53,000 still no light. It did come on for a second one time when I was towing the boat, but after I shut the truck off it never came back on.
Reply With Quote
  #38  
Old 09-11-2006
fx4me's Avatar
Member
 
Join Date: May 2005
Location: CA
Posts: 1,507
Actually, upon reflection, my check engine light comes on several times a day right before I start it, but then goes off the second it starts....

SHOULD I BE WORRIED?!?!?! OMGWTFBBQ!!!!11!
Reply With Quote
  #39  
Old 09-12-2006
mudranger96's Avatar
Member
 
Join Date: Oct 2005
Location: Lehigh Acres, FL
Posts: 2,549
Quote:
Originally Posted by fx4me
Actually, upon reflection, my check engine light comes on several times a day right before I start it, but then goes off the second it starts....

SHOULD I BE WORRIED?!?!?! OMGWTFBBQ!!!!11!

Man you should really get that checked out i would stop driving it till you figure out what is wrong
Reply With Quote
  #40  
Old 09-12-2006
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Mine went on around 45K.

Needed Plugs, Injectors, emissions system purge........basically a wack load of crap needed replacement........bonus was I just bought it and everything was under warranty.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
First Ranger, First Post widriga Member Introductions 5 05-13-2015 01:27 PM
First Post, First Day, First Car. Sierra Invenio Member Introductions 8 05-12-2015 12:34 PM
"Check Engine" light just came on for the first time da11en47 General Technical & Electrical 1 10-07-2010 10:39 PM
problem with engine and check engine light warner.325 SOHC - 2.3L & 2.5L Lima Engines 5 12-09-2009 04:48 AM
Check Engine Light..first problem ever with my truck Kevin89 2.9L & 3.0L V6 Tech 14 07-01-2009 03:26 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.