3rd brake light/blinker/abs light - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-11-2006
NewfieRanger's Avatar
Member
Thread Starter
 
Join Date: Feb 2006
Location: Newfoundland,Canada
Posts: 74
3rd brake light/blinker/abs light

Last week my abs came on and the speedo on occassion acts funny.. now i know from reading the forum that this is most likly the sensor in the rear dif... but last night my right blinker when turned on just stays lit and the rear 3rd brake light is also lit when the headlights are turned on... if you turn on the blinker the 3rd brake light also turns off.. any ideas?
Reply With Quote
  #2  
Old 03-11-2006
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Quote:
Originally Posted by NewfieRanger
but last night my right blinker when turned on just stays lit and the rear 3rd brake light is also lit when the headlights are turned on... if you turn on the blinker the 3rd brake light also turns off.. any ideas?
Could be the Multifunction (turn/wash/wipe/hi-lo) Switch. It can give a variety of strange symptoms when it goes bad.
Reply With Quote
  #3  
Old 03-11-2006
NewfieRanger's Avatar
Member
Thread Starter
 
Join Date: Feb 2006
Location: Newfoundland,Canada
Posts: 74
where is that located.. any chance it could just be a bad bulb or fuse?
Reply With Quote
  #4  
Old 03-11-2006
NewfieRanger's Avatar
Member
Thread Starter
 
Join Date: Feb 2006
Location: Newfoundland,Canada
Posts: 74
I just went out then to wash the truck as its mild here today for a change.. and the blinker/ brake light are fine again... i wonder was it the cold weather... ice build up .. condensation? trailer hitch plug maybe?
Reply With Quote
  #5  
Old 03-11-2006
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Quote:
Originally Posted by NewfieRanger
where is that located.. any chance it could just be a bad bulb or fuse?
If it were a fuse, things would be off at the wrong time but you have stuff that is on at the wrong time. If it were a bulb, I don't think it could make the third brake light come on with the turn signal.

Bad grounds can sometimes make odd combinations of things happen but your symptoms don't seem right.

The Multifunction Switch is the combo switch on the left of the column with turn signals and hi/low beams. I thought it might be that because it controls the brake and turn signal logic and has headlight functions, too.
Reply With Quote
  #6  
Old 03-11-2006
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Just to confuse the issue some more, here's another idea. The taillight/brake light/turn signal wiring and the ABS/VSS wire all go through a common connector that sometimes causes multiple electrical problems. It is a large 40-pin connector below the driver seat and is accessible only from under the truck.

Unscrew the center bolt, open it up and look for water or corroded terminals inside. Even if there is none, it is good preventative maintenance to pack this vulnerable connector with dielectric grease, available at Ford dealers and auto parts stores.
Reply With Quote
  #7  
Old 03-11-2006
Trigger01's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Oct 2005
Location: Knoxville, TN
Posts: 18,788
Your truck may possessed.... if it's not that I wouldn't have a clue.
Reply With Quote
  #8  
Old 03-11-2006
NewfieRanger's Avatar
Member
Thread Starter
 
Join Date: Feb 2006
Location: Newfoundland,Canada
Posts: 74
well Bob, maybe it is the connector under the seat or maybe it is the multiswitch.. everything is fine when the headlights are NOT turned on.. as soon as you turn on the headlights.. thats when the problem occurs
Reply With Quote
  #9  
Old 03-18-2006
NewfieRanger's Avatar
Member
Thread Starter
 
Join Date: Feb 2006
Location: Newfoundland,Canada
Posts: 74
I have still havent found the source of the problem.. All the Bulbs seem fine.. the only thing that i do notice is that when the lights are turned off , the drl's will flicker from time to time.. but as i mentioned when you turn the headlights on.. the right blinker wont work , and the 3rd high mount brakelight stays on at all times..

I really wifh i knew what it was
Reply With Quote
  #10  
Old 04-02-2006
NewfieRanger's Avatar
Member
Thread Starter
 
Join Date: Feb 2006
Location: Newfoundland,Canada
Posts: 74
well the weather was fine today so i looked at the trailer hitch plugs, the plug under the chassis (under the seat) and took out the rear taillights..cant seem to find the problem.. I guess the only ohter thing it could be would be the headlight switch? how can i tell?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Left blinker and brake light not working on trailer connector!? ReelMagic15 General Technical & Electrical 6 07-09-2009 12:27 AM
3rd Blinker Mod? malydeen Snapshots 46 08-16-2008 11:50 PM
Quick ? about 3rd brake light/cargo light! 05RangerXLT General Ford Ranger Discussion 7 04-23-2007 09:40 PM
ABS Light Brake Light, Brake problems, Bob? Redneckstone General Ford Ranger Discussion 4 10-07-2006 06:36 PM
3rd brake light Cargo light ? Ranger1 Exterior Semi-Tech 7 08-03-2005 12:35 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:42 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.