Left blinker and brake light not working on trailer connector!? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-07-2009
ReelMagic15's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: Warwick, RI
Posts: 24
Left blinker and brake light not working on trailer connector!?

On my trailer connector i have a 'line of fire' led strip and when i brake and use my left blinker it doesnt work. The strip isn't bad cuz i checked it on my friends truck. I cant figure out which wire goes to the left blinker/ brake before the yellow wire that goes into the trailer connector. Any help would be great, i use my truck everyday for towing boats and already have a 5-day tag for a bad light on my truck.
Reply With Quote
  #2  
Old 07-07-2009
VW TANK's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2008
Location: Ridgewood,NJ
Posts: 162
is it a factory harness? check fuse 3 or 7, i forget which
Reply With Quote
  #3  
Old 07-07-2009
Johnbaum13's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2008
Location: Dallas, TX
Posts: 2,343
Maybe the line of fire is low on blinker fluid? I've heard those LEDs go through the fluid faster......
Reply With Quote
  #4  
Old 07-07-2009
ReelMagic15's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: Warwick, RI
Posts: 24
Icon14

well there is plenty of blinker fluid in the strip as well as brake fluid so i dont think thats the issue.
Reply With Quote
  #5  
Old 07-07-2009
ReelMagic15's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: Warwick, RI
Posts: 24
Quote:
Originally Posted by VW TANK View Post
is it a factory harness? check fuse 3 or 7, i forget which
ok i will check that in the morning and let you know if that fixed anything.
Reply With Quote
  #6  
Old 07-08-2009
IN2 FX4's Avatar
Member
 
Join Date: Feb 2005
Location: Costa Mesa, CA
Posts: 855
Check to make sure the ground is good on the led strip. Also make sure the polarity is correct. My led strips have diodes in them and will not work if the polarity is reversed.
Reply With Quote
  #7  
Old 07-09-2009
ReelMagic15's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: Warwick, RI
Posts: 24
'VW TANK' was correct; fuse number 7 was missing! IDK how it went missing but all i know is that it works now. Thanks Dan
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Brake lights not working. It's not the brake switch. ColinGooseHall General Technical & Electrical 3 05-01-2015 08:35 PM
Brake and Signal Lights Not Working After Hooking Up Trailer. derek89 General Technical & Electrical 2 04-18-2013 08:49 PM
Want to Buy: 93-05 brake light socket and connector - TX DFWSignals89 Interior, Exterior, Electrical, & Misc. 0 02-14-2012 11:52 PM
98-99 Ford Ranger back up light connector socket and connector DFWSignals89 General Technical & Electrical 3 01-31-2012 04:12 PM
3rd brake light/blinker/abs light NewfieRanger General Technical & Electrical 9 04-02-2006 07:35 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:17 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.