alt won't charge my battery - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-21-2011
Member
Thread Starter
 
Join Date: Mar 2010
Location: Toppenish,WA
Posts: 66
alt won't charge my battery

i have put 2 different alternaters in my truck and it still won't charge the battery and the battery light stays on? i would appreciate help
Reply With Quote
  #2  
Old 01-21-2011
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
have you tested your battery?
Reply With Quote
  #3  
Old 01-21-2011
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
Is there anything wrong with the wire going from the alternator to the battery?
Reply With Quote
  #4  
Old 01-21-2011
STUPIDHEAD11's Avatar
Member
 
Join Date: Oct 2010
Location: Melbourne, Florida
Posts: 219
there are obviously numerous possibilities here. for grins and giggles what battery are you running (walmart. red top etc). If battery test ok then inspect all grounds as they will cause you to lose power and if bad enough your battery will appear as if it isnt charging. next (this is going to be a pain) check wires from back of alternator to battery and feel along the cable for corrosion inside the casing. with all the salt they put down up there it isnt out of the question.
Reply With Quote
  #5  
Old 01-21-2011
Member
Thread Starter
 
Join Date: Mar 2010
Location: Toppenish,WA
Posts: 66
i just bought a new battery its a federal 550
Reply With Quote
  #6  
Old 01-21-2011
rcmustang's Avatar
Member
 
Join Date: Jun 2010
Location: Los Angeles
Posts: 173
Check for the fusible link from the alt to the solenoid.
Reply With Quote
  #7  
Old 01-22-2011
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Also check your fuses, number 14 under the hood should be a 30 amp for Generator Voltage Regulator. Check the small wires on the alternator for corrosion if they feel brittle or look green they need to be replaced. Also dont rely on the dummy light or gauge, use a volt meter to get the voltage at the battery.


Quote:
Originally Posted by rcmustang View Post
Check for the fusible link from the alt to the solenoid.
The solenoid on the fender died in 98.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Battery light, No charge off alternator. AK96 General Technical & Electrical 7 11-19-2014 11:27 PM
Battery won't hold a charge swmich General Technical & Electrical 3 01-11-2013 04:46 PM
Battery Charge Question Mykhael General Technical & Electrical 0 06-06-2009 11:52 AM
Bad Alt, now new alt and Batt light? hotrod88 General Technical & Electrical 3 09-12-2008 06:32 AM
Battery Light , Alternator bad, truck stalling, wont hold charge ......... pushdeck General Technical & Electrical 5 11-09-2006 12:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.