Blinker problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-04-2014
Diesel_Brad's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: PA
Posts: 211
Blinker problem

I have an issue with my 04.
Over the winter the left blinker would Sometimes blink fast. If you pulled down on the handle a little, it would blink normal. Then the interment problem went away.

Well last week the problem came back but ALL the time. Both my front and rear lights work, but the left side is fast. I figured it was the Multifunction switch, so I bought anew aftermarket one. Put tha in tonight, and still have the same problem.

Suggestions?
Reply With Quote
  #2  
Old 06-04-2014
ianyboy's Avatar
Member
 
Join Date: Mar 2013
Location: Quebec City, QC, Canada
Posts: 302
Ground issues on the multiswitch?
Blinker module is shot?
Reply With Quote
  #3  
Old 06-04-2014
Diesel_Brad's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: PA
Posts: 211
What is a blinker module?
Reply With Quote
  #4  
Old 06-04-2014
Diesel_Brad's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: PA
Posts: 211
Found it. Bad ground at the taillight. Someone tapped into it for the cap wiring with one of those scotch locks JUNK and it corroded the wire. It was back feeding thru the running light to make a circuit and it was not as bright as the other taillight. Cut all that BULL S#IT out and put a heat shrink butt connector In. Problem solved
Reply With Quote
  #5  
Old 06-04-2014
99offroadrngr's Avatar
TOYOTA
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
Quote:
Originally Posted by Diesel_Brad View Post
Found it. Bad ground at the taillight. Someone tapped into it for the cap wiring with one of those scotch locks JUNK and it corroded the wire. It was back feeding thru the running light to make a circuit and it was not as bright as the other taillight. Cut all that BULL S#IT out and put a heat shrink butt connector In. Problem solved
glad you found your problem. I hate when people half *** things
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Flasher/Blinker Relay problem. PickupMan92 General Technical & Electrical 3 08-20-2012 11:46 PM
Blinker Problem. ShockFuel General Technical & Electrical 11 04-11-2007 09:27 AM
Please help...left blinker going crazy gone ballistic General Technical & Electrical 10 10-04-2005 11:56 PM
Blinker mod EdgedPike General Technical & Electrical 2 10-03-2004 04:25 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:46 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.