blown fuses - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-25-2008
htjunkie's Avatar
Member
Thread Starter
 
Join Date: Apr 2007
Location: The Lone Star State
Posts: 1,286
blown fuses

I'm having the turn signal fuse blow every once in a while. This doesnt happen ONLY when I have the signal on..it happens at random times. so far..3 times in 2 days. Running lights are still on, just the turn/hazard lights don't work. Any ideas???????????????
Reply With Quote
  #2  
Old 02-25-2008
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
Check both your front and rear signal plugs and harnesses.....check for chaffing on the wiring...that could possibly be your problem.
Reply With Quote
  #3  
Old 02-25-2008
htjunkie's Avatar
Member
Thread Starter
 
Join Date: Apr 2007
Location: The Lone Star State
Posts: 1,286
Thanks. I was just wondering...why is it taking so long to blow? I'll check the wiring tomorrow.
Reply With Quote
  #4  
Old 02-25-2008
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
I think some road grit got in one of those windshield eyeballs causing tearing that is shorting out the blink modulator for that eye .
Reply With Quote
  #5  
Old 02-26-2008
htjunkie's Avatar
Member
Thread Starter
 
Join Date: Apr 2007
Location: The Lone Star State
Posts: 1,286
I have contacts in...so
I cleaned them...seemed to help. Thanks man..
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
keep blowing lighting fuses :( crucialcolin General Technical & Electrical 7 09-06-2008 08:11 PM
Blowing brake/hazard & signal fuses Ironelk General Technical & Electrical 3 01-17-2007 07:33 PM
blowing fuses rynzingg Audio & Video Tech 18 01-09-2006 12:13 AM
Question about relays/fuses 5.0SVT3.0XLT 2.9L & 3.0L V6 Tech 6 06-08-2005 09:37 AM
dash electronics dead...poppin fuses Alon General Technical & Electrical 11 05-15-2005 05:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:35 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.