a/c problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-01-2010
Member
Thread Starter
 
Join Date: Jan 2010
Location: king george virginia
Posts: 137
a/c problem

i have a 93 3.0l auto that the a/c compresser is not turning on however the light on the hvac controls inside is on i have no idea what the problem is and no idea what all to check i do know however that power is getting from the switch to the compresser after that im lost any ideas would be appreciated
Reply With Quote
  #2  
Old 08-01-2010
j99ranger4x4's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: Delaware, OH
Posts: 1,381
Do u have freon in system? Low or no freon will make it not kick on.
Reply With Quote
  #3  
Old 08-01-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
If there is power at the compressor , most likely you need to replace the compressor clutch. Sometimes just disassembling and cleaning the clutch will solve the problem.
Reply With Quote
  #4  
Old 08-01-2010
StrangerRanger's Avatar
Member
 
Join Date: Jan 2009
Location: The 253
Posts: 756
Quote:
Originally Posted by j99ranger4x4 View Post
Do u have freon in system? Low or no freon will make it not kick on.
Ding!

Or a faulty low pressure switch. Check to make sure there is stuff in the system first. It is rarely a wiring issue.
Reply With Quote
  #5  
Old 08-01-2010
j99ranger4x4's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: Delaware, OH
Posts: 1,381
Yeah freon is more likely than other things to happen. Start w simple stuff first.
Reply With Quote
  #6  
Old 08-07-2010
Member
Thread Starter
 
Join Date: Jan 2010
Location: king george virginia
Posts: 137
ok thanks guys...i got bigger problems than that now unfortunatly
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
What part is this? (pic) Blower problem, this the problem? stuck on vent! ChargerOnDavins General Technical & Electrical 4 10-03-2010 06:58 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:46 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.