Dash lights..... - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-24-2008
Shaklakan's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: La Habra CA
Posts: 1,100
Dash lights.....

Ok so i jumped my friends car to get it started and when i grounded to my frame for the jump i grounded to the alternator bracket and it made a spark i was like ok that's pretty normal well when we got everything going i turned on my lights and drove away only to realize that my dash lights weren't working and whenever i turned on my headlights the radio would shut off and turn back on. Well i replaced the fuse and when i turned everything on my dome light shut off the fuse popped to the dash lights and my dome light came back on. I know its a short to ground somewhere but i have no clue where to start looking because i don't wanna take my dash apart. Any ideas guys if no one knows im gonna ignore it until i put my new dash in but thats not for awhile.
Reply With Quote
  #2  
Old 09-24-2008
Member
 
Join Date: Nov 2005
Location: Elizabeth City, NC
Posts: 767
I normally don't believe in coincidences.

This problem sounds like the headlamp switch has gone bad.

I'm looking at a 93 schematic, but all those items get power either bussed or switched at the headlamp switch. It's also a common failure item.

Verify that your chassis to engine ground strap is good too. May be located from the firewall to the block, near the wiper motor.
Reply With Quote
  #3  
Old 09-24-2008
Shaklakan's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: La Habra CA
Posts: 1,100
Chassis to engine ground strap is good and my headlight switch is good i just got done checking everything on that switch with a test light.
Reply With Quote
  #4  
Old 09-26-2008
Shaklakan's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: La Habra CA
Posts: 1,100
anyone got any ideas i don't have any lights.....
Reply With Quote
  #5  
Old 09-26-2008
jeremy4876's Avatar
Member
 
Join Date: Apr 2008
Location: Elyria Township
Posts: 98
Did you check the bulbs behind the gauges ? It's not hard to get to them and in my 94 I would have blown bulbs all the time . Good luck
Reply With Quote
  #6  
Old 09-26-2008
Shaklakan's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: La Habra CA
Posts: 1,100
but see the bulbs are good its the fuse that keeps blowing.
Reply With Quote
  #7  
Old 10-01-2008
Shaklakan's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: La Habra CA
Posts: 1,100
you guys suck at this lol. i figured it out anywho it was my dimmer switch wire to my ohc it had been worn down and was grounding out. Put some electrical tape around it and a fuse and i was good to go. Thanks guys...... /endsarcasm
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
no dash lights/heat panel lights, all others work AK96RANGER General Technical & Electrical 9 08-09-2014 09:16 PM
Rear Lights and Dash Lights are out? SportyDog General Technical & Electrical 3 07-18-2012 09:56 PM
Dash Swap 95 plus dash in a 94 Downey Interior Semi-Tech 19 11-04-2009 09:47 PM
Dash Lights and Instrument Panel Lights... Colors??? bdc217 General Technical & Electrical 8 07-02-2007 09:26 PM
parking lights and dash lights kevman41635 2.9L & 3.0L V6 Tech 8 07-04-2006 11:03 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:52 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.