EATC self diagnostic.. Bob or John help me out! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-13-2006
RF Veteran
Thread Starter
 
Join Date: May 2005
Location: College Station, TX
Posts: 5,782
EATC self diagnostic.. Bob or John help me out!

I am trying to do the self-diagnostic now that I've got this whole deal set up. The test light comes on and dims with the wheel, so I know the fan controller is good. When I try to run the self-diagnostic, it just turns off.

Press and hold OFF, press FLOOR while holding OFF, and then release both and press AUTOMATIC right? Am I doing something wrong?
Reply With Quote
  #2  
Old 01-13-2006
RF Veteran
Thread Starter
 
Join Date: May 2005
Location: College Station, TX
Posts: 5,782
Nevermind! I GOT IT! It all works!

I am kinda curious though... I tested it outside the truck (2003 Ranger with 1999 Explorer components) and I got the 888 code... shouldn't I get the 115 or 125 codes though? Because it is not hooked up to the OBDII connector?
Reply With Quote
  #3  
Old 01-13-2006
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
You might think so, but there are variations in the firmware that cause quite a few differences. Don't ask me why. Ask Visteon or Ford, lol.

If it's happy, they you be happy!

[sung to the tune of "Don't Worry, Be Happy"]

EATC tests just right
Might put it in tonight
Don't worry, be happy

Code showed up as 8-8-8
It's time to celebrate
Don't worry, be happy...

[Okay, I'm a nitwit -- so sue me...]
Reply With Quote
  #4  
Old 01-13-2006
Strider0O0's Avatar
Member
 
Join Date: Jul 2004
Location: Philadelphia, PA
Posts: 3,588
i dont know about anyone else, but i can't wait for john's new cd to come out, lol.
Reply With Quote
  #5  
Old 01-14-2006
RF Veteran
Thread Starter
 
Join Date: May 2005
Location: College Station, TX
Posts: 5,782
I'll take 2!
Reply With Quote
  #6  
Old 01-14-2006
blkb3's Avatar
Member
 
Join Date: Oct 2005
Location: Tolleson, Az
Posts: 443
Quote:
Originally Posted by n3elz
You might think so, but there are variations in the firmware that cause quite a few differences. Don't ask me why. Ask Visteon or Ford, lol.

If it's happy, they you be happy!

[sung to the tune of "Don't Worry, Be Happy"]

EATC tests just right
Might put it in tonight
Don't worry, be happy

Code showed up as 8-8-8
It's time to celebrate
Don't worry, be happy...

[Okay, I'm a nitwit -- so sue me...]
LMAO......thats great stuff
Reply With Quote
  #7  
Old 01-14-2006
Member
iTrader: (2)
 
Join Date: Aug 2004
Location: Grayson, Kentucky
Posts: 617
That's gonna go platinum for sure!!!
Reply With Quote
  #8  
Old 01-14-2006
TheForce02's Avatar
Member
 
Join Date: Jun 2004
Location: Chino, CA
Posts: 846
Quote:
Originally Posted by eDg3 oF cHa0s
That's gonna go platinum for sure!!!

no Aluminum!!! (compliments of Larry the Cable Guy)
Reply With Quote
  #9  
Old 01-15-2006
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
Hey, that's cool -- have you seen the price of aluminum lately?

Ha ha! Thanks for the comments, lol! (way to hijack a thread, John... )
Reply With Quote
  #10  
Old 01-16-2006
RF Veteran
Thread Starter
 
Join Date: May 2005
Location: College Station, TX
Posts: 5,782
It's ok John, I won't report you to the proper authorities! I was done with this thread anyways I just want 20% royalties on your album sales!
Reply With Quote
  #11  
Old 01-16-2006
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
Let's see, 20% of nothing is....carry the one...uh...I need a calculator for that, I'll get back to you.
Reply With Quote
  #12  
Old 01-16-2006
RF Veteran
Thread Starter
 
Join Date: May 2005
Location: College Station, TX
Posts: 5,782
Ok then your firstborn child will do nicely instead!
Reply With Quote
  #13  
Old 01-16-2006
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
She's in England now. I think she'd want some say in that though, lol.
Reply With Quote
  #14  
Old 05-07-2007
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
not to bring up an old post, but how do you exactly do the self diagnostic?

Quote:
Originally Posted by Gearhead61
Press and hold OFF, press FLOOR while holding OFF, and then release both and press AUTOMATIC
is that the proper way?
Reply With Quote
  #15  
Old 05-07-2007
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,833
That's the correct procedure, just be quick about it. If you don't push the AUTOMATIC within 2 seconds of releasing the others, it won't work. When the self test is finished, you should return the system to normal operation by pushing the DEFROST button.

This was covered in John's How-to.
Reply With Quote
  #16  
Old 05-07-2007
RF Veteran
Thread Starter
 
Join Date: May 2005
Location: College Station, TX
Posts: 5,782
Yeah man can't you read the how-to? Haha just playin. Talk about a blast from the past.
Reply With Quote
  #17  
Old 05-08-2007
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
Quote:
Originally Posted by Gearhead61
Yeah man can't you read the how-to? Haha just playin. Talk about a blast from the past.
ha ha ha .......after reading that how-to about a 100x and getting frustrated cause the stupid thing wont work right ......i am soooo frustrated right now.....everythin comes on, but the a/c compressor wont engage (but the efan will come on when the a/c is on......), when the HU is off it blows on high out the defrost vents, and the fan speed switch only works the fan in fast and faster modes...........

i want this to work!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Newbie here. needs help with diagnostic. demaxx1 Drivetrain Tech 2 11-24-2009 10:50 PM
EATC for a 1993 F-150; Bob, John? optikal illushun General Technical & Electrical 5 06-04-2008 06:02 AM
Question for Bob, John, or anybody, about the tone ring in the rear axle... rngprerunner Drivetrain Tech 13 04-23-2007 12:35 PM
New found respect for Bob and John: Building a circuit Mnemonic General Technical & Electrical 17 08-14-2005 09:24 AM
Diagnostic Mode AllBlackStang General Technical & Electrical 4 02-28-2005 11:10 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:38 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.