Newbie here. needs help with diagnostic. - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-15-2009
Member
Thread Starter
 
Join Date: Nov 2009
Location: K-ville
Posts: 2
Newbie here. needs help with diagnostic.

Hi Gang,
I have an 88 ranger 4x4 purchase about 3 months ago. since I have replaced the inner and outer tie rods and had the front end lined up, also put new tires on this truck. I had a pretty bad vibration, between 35mph and 45 mph. it would then go away then return at 55mph. I put new ujoints and a new center driveshaft bearing. this helped get rid of the vibration between 35-45 mph. but still had the vibration starting at 55mph.

Yesturday I spent a few hours dropping the rear drive shaft and rotating 1/4 turns at the rear axle and the transfer case this made no difference.

I then thought I wonder if this could be in the front end. So I locked the fron hubs and put it in 4x4 and drove straight down the street.. the vibration was terrible! I disengaged the 4x4 and left the fron hubs locked (they're manual) and drove it again terrible vibration also noticticed a clunking noise coming from the right side. I checked the axle u-joints they seemed to be okay. Any one else had a this problem? or any suggestions. I'm not sure if it's the wheel bearings. axle u-joints or the hubs.

Any help would be appreciated!
Dwight.

Last edited by demaxx1; 11-15-2009 at 07:59 AM.
Reply With Quote
  #2  
Old 11-23-2009
Member
Thread Starter
 
Join Date: Nov 2009
Location: K-ville
Posts: 2
Little bump
Reply With Quote
  #3  
Old 11-24-2009
nross's Avatar
Member
 
Join Date: Nov 2008
Location: Binghamton, NY
Posts: 256
The vibration you are decribing to me sounds like a front hub assembly. I drive an 05 and when mine went bad it produced a bad vibration like a tire was skipping down the road, but in the mean time it was just the extra slop in the hub assembly.

Mine started to make a chirping noise, such as a brake clip hitting a rotor kind of. that was the dead give away.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Newbie needs help AZ01Ranger General Technical & Electrical 1 09-11-2009 07:11 AM
Newbie needs ignition switch help jcrane88 General Technical & Electrical 3 06-08-2009 05:55 PM
Another newbie needs help from the Ranger masters 98rangerboy SOHC - 2.3L & 2.5L Lima Engines 12 12-09-2007 11:24 PM
Newbie needs help, (Go figure). rivcyko DOHC - 2.3L Duratec / Mazda L Engines 12 12-03-2007 08:37 AM
EATC self diagnostic.. Bob or John help me out! Gearhead61 General Technical & Electrical 16 05-08-2007 07:19 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:57 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.