Everlasting Doom Light - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-11-2005
Sparki's Avatar
Member
Thread Starter
 
Join Date: May 2005
Location: Richmond, Tx
Posts: 322
Everlasting Doom Light

ok - heres the thing - my inside dome light will NOT go off. well eventually but - when i turn my truck off and shut the door (yes all the way) it wont go off for a LONG time. Also, my Door Ajar light never goes out, even when both doors are shut all the way. People keep telling me to check the manual button in the door jam- i have looked all over, up and down, round and round that darn thing and i cant find anything. Its very aggrevating. please help

sparki

(ha newly acquired nickname)
Reply With Quote
  #2  
Old 07-11-2005
mjktg99's Avatar
Member
 
Join Date: Jul 2004
Location: Lanoka Harbor, NJ
Posts: 201
The door ajar sensor(what is keeping your dome light and door ajar light on) is attached to the latch on the inside of the door. Its the only latch there, so you cant miss it. These have been known to go bad. Its not that un common for them to do exactly what you are describing. The fact that your dome does eventually go out, means it might just be dirty.

A fix for this is to absolutely drench it in a lubricant spray. WD40 is ok, but will attract more dirt eventually. Try using a white lithium grease spray if you can get some. It will work just as well without the dirt. After spraying the latch, open and close your door many times, you may want to respray and do it all over again.

If this doesnt fix it, then you might just have a bad sensor. I dont believe they are too expensive, just a biothc to replace.

Hope this helps!

EDIT: After thinking for a minute, the reason it does go off is because our trucks have battery saver feature that turns off the power after 10mins. THis may be the reason yours goes off. If this is the case, then you might just have a bad sensor. But try cleaning it first like I described above and see if that helps before you go spending money.
Reply With Quote
  #3  
Old 07-11-2005
Rangerboy03lvl2's Avatar
Member
 
Join Date: Jun 2004
Location: Colorado, Lone Tree
Posts: 891
exactly what he said.... but id clean it out with the wd40 first... then use the white lithium grease spray so it doesnt attract more dirt... if that does not work it is the sensor... and they are not that bad to replace... do them all the time at work...
Reply With Quote
  #4  
Old 07-11-2005
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
if i remeber correctly there not to expansive....
Reply With Quote
  #5  
Old 07-12-2005
Sparki's Avatar
Member
Thread Starter
 
Join Date: May 2005
Location: Richmond, Tx
Posts: 322
thanks guys for the advice. i will definately try that. I hope its just dirty - bc i noticed on a good day (very rare) it will stay off. well work properly. Well im going to try it right now... ill let you know. man i hope this works!! :)
Reply With Quote
  #6  
Old 07-12-2005
gatorblue92's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Delaware
Posts: 8,238
mine did the exact same thing and i soaked it with contact cleaner and its been working fine since
Reply With Quote
  #7  
Old 07-12-2005
Sparki's Avatar
Member
Thread Starter
 
Join Date: May 2005
Location: Richmond, Tx
Posts: 322
Thank You Soooo Much!!

WOW!! I have got to be the happiest person in the world right now. I took ya'lls advice and it worked (not that i had any doubt - you just have to know my luck)! everything is back to normal - everything is perfect. thank you guys so much! ya'll fixed my problem that Planet Ford claimed to fix but was just to ****** lazy to spray a little wd40. thanks a million that thing was really annoying i have been w/o a dome light for a month or so. :)
Reply With Quote
  #8  
Old 07-12-2005
Sparki's Avatar
Member
Thread Starter
 
Join Date: May 2005
Location: Richmond, Tx
Posts: 322
nice ranger. lol. have you done anything to the engine? i really want to take off the governer - it kicks in at 92 makes it hard to pass people sometimes. :( any suggestions?
Reply With Quote
  #9  
Old 07-12-2005
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Posts: 17,221
Quote:
Originally Posted by mini_munki84
nice ranger. lol. have you done anything to the engine? i really want to take off the governer - it kicks in at 92 makes it hard to pass people sometimes. :( any suggestions?
I think the governor is hard or impossible to take off, anyways theres a chance someone would race their engine till it explodes.

My tips for driving faster in your ranger

1. Get towed by a mustang at 110
2. Try to hit the limit while going downhill, you can prolly get 98 or something
3. Bigger tires will make you go faster, but it'll take a tiny bit more time to get up to speed.

Do ya really pass people at 92? There is barely enough road from one side of my town to the other that is straight. All curvey, and you can't see cars coming. One spot out the road I *could* get up to 95, but last time I was there with a friend, his hood came unlatched at 100 and smashed the window, freaky as hell.

Aaron
Reply With Quote
  #10  
Old 07-12-2005
Sparki's Avatar
Member
Thread Starter
 
Join Date: May 2005
Location: Richmond, Tx
Posts: 322
thats nuts

thats too funny. i have passed someone going that fast - usually an eighteen wheeler - i hate it when they throw rocks on my truck. the same day if not the next day one of those ******** chipped my windshield right in the middle. grrr. I dont think i would blow my engine up - my last ranger (tho it had a bigger engine - which i really miss) it had a 4.0L V6 automatic i used to get that bad boy up to 100 easy. it came in handy when i was running late for work. sucks to hear about your friends car - ya'll didnt wreck or anything did you? that would suck even worse.
Reply With Quote
  #11  
Old 07-12-2005
TReff's Avatar
Member
 
Join Date: Jun 2004
Location: La Porte,Tx
Posts: 905
www.bamachips.com
Doug is the MAN ..he can hook you up with a tuner or a chip to help with the gov. and or rev limiter..
Reply With Quote
  #12  
Old 07-12-2005
Strider0O0's Avatar
Member
 
Join Date: Jul 2004
Location: Philadelphia, PA
Posts: 3,588
best way to get rid of the gov. is to buy a performance chip from Doug at Bamachips. he has a few different chips available for our trucks, and you never hear anything but satisfaction from those who have bought from him.

btw, what engine does your truck have? just curious!

EDIT: Tommy beat me to the plug, lol.
Reply With Quote
  #13  
Old 07-12-2005
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
Quote:
Originally Posted by TReff
www.bamachips.com
Doug is the MAN ..he can hook you up with a tuner or a chip to help with the gov. and or rev limiter..
best $ you could spend on it
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Doom Light Fuse Z7What General Technical & Electrical 7 03-18-2011 10:21 AM
My 2000 "sas" Ranger of doom! Meatpuppet Vehicle & Meet Videos 13 01-07-2011 08:02 AM
battery light ABS light dim light RangerSkippyRoo General Technical & Electrical 3 05-25-2009 11:25 AM
doom light? anger_ranger General Ford Ranger Discussion 41 10-13-2006 10:01 PM
replacing fog light with driving light Topper_Harlee General Technical & Electrical 4 08-12-2005 04:42 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:51 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.