explorer sport trac cluster trouble with intall. - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-25-2005
zabeard's Avatar
who?
Thread Starter
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
explorer sport trac cluster trouble with intall.

i bought a explorer cluster 99-01 for my 03 ranger, today while installing i got it all installed and the 4x4 lights and OD lights do not work. so i pulled it back out and checked the bulbs... all good.

finally i pulled the unit out and swapped the backing on the guages(put my original white caseing behind the new guage pieces) and still the lights do not light up.

i can here the 4x4 engage so i know its working but it still does not light up.

anyone else have this issue? anyone have an idea?


thanks.
Reply With Quote
  #2  
Old 12-25-2005
RF Veteran
 
Join Date: May 2005
Location: College Station, TX
Posts: 5,782
is there a fuse that isn't working? Or a connection that came loose?
Reply With Quote
  #3  
Old 12-25-2005
zabeard's Avatar
who?
Thread Starter
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
havnt checked any fuses, but i know its all plugged in. i just cant see how 3 lights would be controlled by one fuse, but ill check it when i get home.
Reply With Quote
  #4  
Old 12-25-2005
hougy's Avatar
Member
 
Join Date: Jul 2005
Location: Cobb, GA
Posts: 206
Dumb question...But you did get the cluster with the 4x4 cut outs right?

A few other people had this problem also, but usually their lights stayed on (like check engine). I'd take it out and make sure all the wiring is good behind the cluster, no fraying or anything. Also try switching bulbs
Reply With Quote
  #5  
Old 12-25-2005
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Did you forget to plug in your headlight switch??
Reply With Quote
  #6  
Old 12-25-2005
zabeard's Avatar
who?
Thread Starter
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
^^^ that would be my problem i found that out after i gave up and just decided to put it back together and then it all worked. come to find out that headlight switch needs to be plugged in just like bob said.

i feel kinda stupid now but it is fixed. lol

thanks bob
Reply With Quote
  #7  
Old 12-27-2005
Member
iTrader: (2)
 
Join Date: Aug 2004
Location: Grayson, Kentucky
Posts: 617
Glad to see ya got your Christmas present working Zach!!!
Reply With Quote
  #8  
Old 12-27-2005
vansnxtweek's Avatar
Member
 
Join Date: Feb 2005
Location: USA
Posts: 2,666
pictures!!!!!!!!!!!
Reply With Quote
  #9  
Old 12-27-2005
zabeard's Avatar
who?
Thread Starter
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
ha, no pictures right now. for some reason the speedo and odo didnt work. worked when i tested it with the battery but does not work right now, so i swapped the center piece back in.

i think i will figure it out sometime, but no rush.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
For Sale: Explorer/Ranger/Sport Trac Instrument Cluster - CO forrestv Interior, Exterior, Electrical, & Misc. 5 09-22-2012 12:18 AM
For Sale: Explorer Sport-Trac/Sport White-Face Cluster and RH 06 Corner (MA) 99offroadrngr Interior, Exterior, Electrical, & Misc. 9 05-07-2010 12:50 PM
Explorer sport/sport trac seats 99offroadrngr Interior Semi-Tech 31 04-27-2010 05:18 PM
Explorer and Explorer Sport Trac leaf springs.... lifted97ranger General Technical & Electrical 10 12-20-2006 04:29 PM
Price for a Sport Trac Guage cluster. edgeofthecliff Interior Semi-Tech 3 08-28-2004 01:06 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:21 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.