fog light woes - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-18-2007
i_luv_strats's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: bremerton wa
Posts: 338
fog light woes

for awhile my passenger side fog light has been flashing on and off, now it went dead, so i went to shucks and picked up a new bulb and still doesnt work. any ideas on where to start figuring out where and what is going wrong. i followed the wire harness away from the fog light and it blends into a large bundle of stuff i dont particularly want to get into with my little knowledge on electrical stuffs.
Reply With Quote
  #2  
Old 09-18-2007
bricesedge03's Avatar
Member
 
Join Date: Apr 2007
Location: columbia sc
Posts: 388
if it was turning on and off like that there is a loose connection somewhere. probably right behind the light. Or maybe the ground. check to see if something is loose.
Reply With Quote
  #3  
Old 09-18-2007
Member
 
Join Date: Nov 2005
Location: Elizabeth City, NC
Posts: 767
It should share its ground with the other lamps on that side.

Use a voltmeter. Check the foglamp connector for power, using the other pin as ground. If no power, move the ground lead to chassis ground. If you have power then, you need to follow the ground wire to the splice upstream, or simply cut it, put a terminal on it and ground it to the chassis.

The BK (Black) wire is the ground.
Reply With Quote
  #4  
Old 09-18-2007
i_luv_strats's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: bremerton wa
Posts: 338
cool, I'll crawl under the truck and see what i can find, would it at all be possible if the bulb i got doesnt work for it and wont light up? it plugged in fine and mounted fine, just a thought.
Reply With Quote
  #5  
Old 09-18-2007
bricesedge03's Avatar
Member
 
Join Date: Apr 2007
Location: columbia sc
Posts: 388
could be the bulb do you have an ohm meter?
Reply With Quote
  #6  
Old 09-19-2007
i_luv_strats's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: bremerton wa
Posts: 338
i've found the problem, it looks like the person that owned the truck before me tried to pull the harness out by the wires and not unclip it, i wiggled the wires and the light came on, if i could find a new harness i could splice it on and be good as new.
Reply With Quote
  #7  
Old 09-19-2007
bricesedge03's Avatar
Member
 
Join Date: Apr 2007
Location: columbia sc
Posts: 388
sweet i called it. you can fix it with solder or new wires?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fog light switch but no fog lights hamricksj General Ford Ranger Discussion 14 03-17-2014 09:26 PM
For Sale: 93-97 3rd Gen Fog lights and Fog Light Brackets - GA MugenCRX04 Interior, Exterior, Electrical, & Misc. 13 03-28-2011 05:41 PM
Wiring up fog lights to factory fog light switch. Ranger_Envy General Technical & Electrical 3 07-27-2009 10:05 PM
dome light woes 2004xlt General Technical & Electrical 2 05-01-2008 03:13 PM
Fog lights on a non fog light truck... melj2000 General Technical & Electrical 2 09-28-2007 12:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:57 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.