Heat blower stopped, then started, now stopped heat works - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-16-2015
Member
Thread Starter
 
Join Date: Feb 2015
Location: Portland
Posts: 2
Heat blower stopped, then started, now stopped heat works

Blower for heat and AC stopped when it started getting cold in NEngland. Then one day started working again for a few weeks, now stopped again. Heat is coming out but no blower. COLD! What could it be and what would it cost to fix? Thanks. Not a mechanic but can fiddle around under the dash.
Reply With Quote
  #2  
Old 02-16-2015
RLong31's Avatar
The Ban Hammer
iTrader: (5)
 
Join Date: Jul 2009
Location: Monrovia, IN
Posts: 2,629
There is a blower motor that probably went bad. It's on the firewall under the hood on the passenger side. Not hard to replace.. I got my replacement from the junk yard for pretty cheap.
Reply With Quote
  #3  
Old 02-17-2015
sheltonfilms's Avatar
Member
 
Join Date: Apr 2010
Location: Knoxville, TN
Posts: 631
Since it stopped, then worked, then stopped again my money is on a corroded blower motor resistor connector.

Name:  Checkyourconnectionsforcorrosion.jpg
Views: 1306
Size:  110.0 KB
Reply With Quote
  #4  
Old 02-17-2015
Member
Thread Starter
 
Join Date: Feb 2015
Location: Portland
Posts: 2
My thought as well, moter blower is fine

how to fix?
Reply With Quote
  #5  
Old 02-17-2015
sheltonfilms's Avatar
Member
 
Join Date: Apr 2010
Location: Knoxville, TN
Posts: 631
Take the connector off and look for corrosion. If it has some you can get small strips of sandpaper and clean it off.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
ac works under 50mph then heater turns on after 50 k00kiem0nster SOHC - 2.3L & 2.5L Lima Engines 9 04-24-2012 01:16 PM
A/C blower only works on full blast, is this a resistor problem? STUPIDHEAD11 General Technical & Electrical 9 12-15-2010 11:14 AM
New battery, then new alternator, then found broken wire... psvines General Technical & Electrical 1 01-01-2010 07:15 PM
AC Fan works then doesn't, huh? RockHardCandy General Technical & Electrical 3 07-20-2009 05:02 PM
Then and Now Toreador4x4 Snapshots 44 02-05-2009 08:43 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:12 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.