Horn Problem with '91 - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-28-2009
Psychedelic_Zuma's Avatar
Member
Thread Starter
 
Join Date: Jan 2009
Location: Troutman, NC
Posts: 15
Horn Problem with '91

My horn doesn't work, which is a problem, because it won't pass inspection without one. I took a test light to it, and there is no electricity going to it, even though the fuse is good. I know that the blue wire is positive and the brown is negative. Should I just check the wires for shorts or something? Any one have a wiring diagram just laying around? Any help is appreciated, I need this done QUICKLY.
Reply With Quote
  #2  
Old 01-31-2009
NATEFX407's Avatar
Member
 
Join Date: Dec 2008
Location: Kawartha Lakes, ON
Posts: 459
Use your test light and check for power at the horn button, then coming out of it, should narrow down the problem.
Reply With Quote
  #3  
Old 01-31-2009
john93rangerstx's Avatar
Member
 
Join Date: Mar 2008
Location: WARWICK RI
Posts: 895
run a wire to the batery and make shure your horn is not junk
Reply With Quote
  #4  
Old 02-01-2009
Psychedelic_Zuma's Avatar
Member
Thread Starter
 
Join Date: Jan 2009
Location: Troutman, NC
Posts: 15
I found the problem, it was the horn relay. I ordered one from Ford, it should be here tomorrow.
Reply With Quote
  #5  
Old 02-01-2009
NATEFX407's Avatar
Member
 
Join Date: Dec 2008
Location: Kawartha Lakes, ON
Posts: 459
Good to hear.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Only one horn button works..anybody else have this problem ? surfrat1 General Technical & Electrical 0 06-23-2015 08:48 PM
Weird horn problem 2000 Ranger PimWaddis General Technical & Electrical 0 09-30-2013 03:16 PM
Stock horn problem karrbass4life General Technical & Electrical 11 07-31-2006 10:20 PM
2004 Owners, how does your horn sound? Mnemonic General Technical & Electrical 25 07-03-2005 07:29 PM
Horn aint workin! Please help! rngprerunner General Ford Ranger Discussion 5 08-26-2004 12:18 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:47 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.