install gone bad.. need help asap! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-31-2006
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
install gone bad.. need help asap!

I was installing a new headunit in my truck last night.. all was well till i put it in the slot. It shut off.. so i was liike no big deal. (i was in a parking lot). So i start to drive home and my windows dont work!. I was like eh whatever at least they are up. It started to rain hardcore and i dont have wipers!

what is going on? is it a fuse.. if so, which one?

ps. i dont have an ownersmanual
Reply With Quote
  #2  
Old 08-31-2006
Member
 
Join Date: Aug 2005
Location: Haverhill, MA
Posts: 1,907
u could always just go threw the fuses and look for one that looks blown? u prob toutch the power wire with ground when u were doing it i GUESSING and the radio was prob on the fuse. idk thats what i can think of. cause i disconnected my battery terminal before i did mine

Nick
Reply With Quote
  #3  
Old 08-31-2006
dangerranger's Avatar
Member
 
Join Date: Aug 2005
Location: muskego, wi
Posts: 536
agreed i bet its the fuse i'll try to look up the fuse spot.
Reply With Quote
  #4  
Old 08-31-2006
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
i believe that fuse spot 17 is the radio fuse!
Reply With Quote
  #5  
Old 08-31-2006
pastfinder's Avatar
Member
 
Join Date: Mar 2006
Location: Washington, DC
Posts: 1,252
Check fuse 20 as well.
Reply With Quote
  #6  
Old 08-31-2006
jrpro130's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
IIRC it's 17...I had the same problem. I bet what happened was wire tape wasn't completely around one of the wires and you shorted it out.

Also, if that doesn't work, check the HU fuses
Reply With Quote
  #7  
Old 08-31-2006
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
it was number 20... thanks man!


holy man these subs hit hard as hell!
Reply With Quote
  #8  
Old 08-31-2006
jrpro130's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
Quote:
Originally Posted by ranger02_4x4
it was number 20... thanks man!


holy man these subs hit hard as hell!
Video...now!!!

At least pics man!!!
Reply With Quote
  #9  
Old 08-31-2006
pastfinder's Avatar
Member
 
Join Date: Mar 2006
Location: Washington, DC
Posts: 1,252
Quote:
Originally Posted by ranger02_4x4
it was number 20... thanks man!


holy man these subs hit hard as hell!

In the spirit of Stephen Colbert....I CALLED IT!!!!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
CV re-install - Need help ASAP winks Drivetrain Tech 5 01-17-2011 09:58 AM
For Sale: Many things; Need gone ASAP - OR TrePaul86 Interior, Exterior, Electrical, & Misc. 77 04-02-2010 02:30 PM
need help ASAP doing install of HID!!! jaycheetwood General Ford Ranger Discussion 2 10-07-2008 08:42 PM
Signal mirror Mod Gone Bad ! I need your help now ! LiquidBullet General Technical & Electrical 1 03-16-2006 12:00 PM
need help asap!!! Bad water leak!!! blkranger Interior Semi-Tech 3 07-07-2005 01:53 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:44 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.