Installed a 200 Amp Alt ( Pictures ) - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-14-2006
Rangerboy03lvl2's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Colorado, Lone Tree
Posts: 891
Installed a 200 Amp Alt ( Pictures )

I installed a 200 amp alternator from Jusnes Modified, and I love it!


I ended up changing out the pullies from the stock alternator to the new one. The stock pully is a little smaller and made a bit of a difference in charging at idle. I also installed a new 'alternator to battery cable' i had also gotten from Jusnes Modified.

Before Hand with the stock alternator was only charging at 13.49 volts and max output was 91 amps.

After installing the 200 amp alt it is charging at 14.69 volts and max output was 189 amps.
I also tested the load on the alternator with everything electrical on or being used and the most it needed was 130 amps of draw. which means the stock alternator was getting its *** kicked since the stock max out put was 91 amps lol.


I am very happy with this install.

Now for some pictures:

Stock vs New :




Before:



Installed :



New "Alternator to Battery" wire :




What do you think?

-Jared
Reply With Quote
  #2  
Old 01-14-2006
OffRoad 4x4's Avatar
Member
 
Join Date: Feb 2005
Location: Escondido, CA
Posts: 301
Recently did a similar installation...
Installed a 160A 3G large case alternator with 4 ga charging cable and a Optima 34 series battery with 1000 CCA.
The alternator came with a smaller pulley than the factory one which provides a constant 14.5V at idle even with the headlights and foglights on.
Even under HEAVY load the alternator maintains 14.5V at 950 rpms.

Very nice supercharger installation.....

OR 4x4
Reply With Quote
  #3  
Old 01-14-2006
HighRollerII's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Jun 2004
Location: Charleston, SC
Posts: 10,066
looks good Jared thats gunna be my next investment..

fit all good right..like direct placement
Reply With Quote
  #4  
Old 01-14-2006
jtslmn720's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Location: Kent State, Kent Ohio
Posts: 7,367
looks good... id do that but not sure what id need it for...
Reply With Quote
  #5  
Old 01-14-2006
Rangerboy03lvl2's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Colorado, Lone Tree
Posts: 891
Quote:
Originally Posted by HighRollerII
looks good Jared thats gunna be my next investment..

fit all good right..like direct placement

yup .... but if you do a 200 amp, you need to change the alternator to battery wire, otherwise you have a chance of fri-ing your wires...

-Jared
Reply With Quote
  #6  
Old 01-14-2006
Bigwill41's Avatar
Member
 
Join Date: Jun 2004
Location: Navasota, Texas
Posts: 4,659
Paypal me some money...

You Rich ****...

Last edited by Bigwill41; 01-14-2006 at 08:26 PM.
Reply With Quote
  #7  
Old 01-14-2006
HighRollerII's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Jun 2004
Location: Charleston, SC
Posts: 10,066
Quote:
Originally Posted by Rangerboy03lvl2
yup .... but if you do a 200 amp, you need to change the alternator to battery wire, otherwise you have a chance of fri-ing your wires...

-Jared

yea upgrade the electrical junk like grounds leads and stuff..i already got the wires for that...

sounds good to me..
Reply With Quote
  #8  
Old 01-14-2006
Member
 
Join Date: May 2004
Location: Fuquay Varina, NC
Posts: 3,048
looks great man! about time you installed that thing!!
Reply With Quote
  #9  
Old 01-15-2006
04lvl2's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Palm Bay, FL
Posts: 5,600
Looks good Jared, nice work.
Reply With Quote
  #10  
Old 01-15-2006
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
i think i need this in a couple weeks
Reply With Quote
  #11  
Old 01-15-2006
rideac1's Avatar
Member
iTrader: (1)
 
Join Date: May 2005
Location: New Kensington, PA
Posts: 1,087
Where'd you get the 200A and how much$$$? I was thinking of getting one because I have a high powered stereo system and stuff.
Reply With Quote
  #12  
Old 01-15-2006
Bigwill41's Avatar
Member
 
Join Date: Jun 2004
Location: Navasota, Texas
Posts: 4,659
Quote:
Originally Posted by rideac1
Where'd you get the 200A and how much$$$? I was thinking of getting one because I have a high powered stereo system and stuff.
http://www.jusnesmodified.com/store/
Reply With Quote
  #13  
Old 01-15-2006
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
read man read ^^^
read the first post.

looks good jared. ive got that added to my list now. lol. i think i need one too.
Reply With Quote
  #14  
Old 01-15-2006
rideac1's Avatar
Member
iTrader: (1)
 
Join Date: May 2005
Location: New Kensington, PA
Posts: 1,087
Quote:
Originally Posted by zabeard
read man read ^^^
read the first post.

looks good jared. ive got that added to my list now. lol. i think i need one too.
Sorry about that, I was too excited and tarded out. haha
Reply With Quote
  #15  
Old 01-15-2006
67cobain94's Avatar
Member
 
Join Date: Jul 2005
Location: Vero Beach, Florida
Posts: 708
Damn there's just too much I need and want now. I need a better paying job or I need to become a pimp.
Reply With Quote
  #16  
Old 01-15-2006
rideac1's Avatar
Member
iTrader: (1)
 
Join Date: May 2005
Location: New Kensington, PA
Posts: 1,087
I'm with you^^^
Reply With Quote
  #17  
Old 01-16-2006
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
Quote:
Originally Posted by rideac1
Sorry about that, I was too excited and tarded out. haha

lol no big deal.
Reply With Quote
  #18  
Old 04-05-2008
Lefty04LevelII's Avatar
Member
 
Join Date: Aug 2005
Location: DFW
Posts: 1,447
bump....for 2 years ago

Anyone got pics of this laying around?

I think my alt took a crap on me today. I was 10-11 miles off-road and had to call a friend out. He tried jumping me and no kick over; just clicks and then a slow die off after 30 seconds of trying to start (per owners manual, IIRC). Thought my PATS was wigging out, but thinking the alt still.

I was towed about 1 miles to a down hill portion where I was able to pop start the truck and drive home. Since home though she won't kick over. I didn't leave any lights on etc and this little 'off-road' trip was actually on city time (I was labbing a site for a potential hike for a program I run). She cranked over fine in the parking lot of work. Anyhow, the alt is off and I'm going to autozone to test it. Unfortunately when un-doing the wiring I the broke the small retaining portion (portion on the alt) for the 2 wire clip (clip is fine).

I'm thinking about a stronger alt, but not sure what will need to be done to do this. Thankfully I have Mon, Tues, and Wed off this week.

UGH, this is NOT how I wanted to spend my tax return money!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Bad Alt, now new alt and Batt light? hotrod88 General Technical & Electrical 3 09-12-2008 06:32 AM
200 amp alt installed !!! tekrsq General Technical & Electrical 25 09-05-2006 07:04 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:41 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.