Need to pass emissions sas help! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-27-2012
EricRanger's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2008
Location: Cary, IL
Posts: 801
Need to pass emissions sas help!

So when I did my sas I just said f*ck it I don't need a speedo ill use my GPS. Well now it's crunch time and I can't get my plates renewed untill pass. The only code (cel) is p0500, witch is vss malfunction because I don't have one. I bought a factory one for the old 8.8 and tried puting over the u joint off my tcase. Nothing. Tried puting it on the cps flywheel and the speedo didn't read anything. Don't really want to buy a new tcase with the sensor in it. I just need to figure something out for a week so I can pass. Any suggestions?
Reply With Quote
  #2  
Old 10-27-2012
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
you need a speed sensor to get a sticker? dam, all i do is fill out a form. I never knew there were vehicle checks, only inspection in canada is a safety.


sounds to me like you should just get a T case and do it right.
Reply With Quote
  #3  
Old 10-27-2012
EricRanger's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2008
Location: Cary, IL
Posts: 801
I was hoping I don't have to do that. I was wondering if there was any way I could fake out the computer to read a pulse signal. So I have enough time to reset and let the systems gather enough data without the cel turning on so I can pass
Reply With Quote
  #4  
Old 10-29-2012
EricRanger's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2008
Location: Cary, IL
Posts: 801
So I tried setting a rearend with working vss on it next to my truck and wired it in. Spun the thing as fast as I could with the truck running. And the speedo didn't read anything..... Fuse is good. Stumped...
Reply With Quote
  #5  
Old 10-29-2012
EricRanger's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2008
Location: Cary, IL
Posts: 801
Ok just realized my abs switch was turned off sence the sas. So I've had no power to my abs modual. Turned it back on now ill retry everything tomorrow.
Reply With Quote
  #6  
Old 10-30-2012
seed60's Avatar
RF Veteran
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
Tcase option is the only thing I've seen. Curious if there's another way.
Reply With Quote
  #7  
Old 12-03-2012
EricRanger's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2008
Location: Cary, IL
Posts: 801
Got it to work and pass! Speedo was about 50% off but worked
Reply With Quote
  #8  
Old 12-04-2012
seed60's Avatar
RF Veteran
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
How'd you get it to work?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 4.0L OHV Emissions help TexasDave 4.0L OHV & SOHC V6 Tech 2 06-14-2013 09:44 PM
Emissions Help needed. RangerThunder10 General Ford Ranger Discussion 0 11-12-2010 08:02 AM
need help, emissions uferd302 General Ford Ranger Discussion 2 04-30-2010 03:26 PM
pass side rear fender damage, need help dmety87 Exterior Semi-Tech 6 06-03-2008 09:54 PM
I Need Help Asap!!! Have To Pass Smog!! mcerwing General Ford Ranger Discussion 5 04-24-2006 08:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:38 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.