New to Forum - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-14-2010
Member
Thread Starter
 
Join Date: Nov 2010
Location: Palm Coast
Posts: 4
New to Forum

Hi,
I am new here on the site. I have a problem with my 98 ranger and was wondering if anyone could help? My wipers as well as power windows and dome light does not work. I have checked all fuses and none are blown. I would appreciate any help.
Reply With Quote
  #2  
Old 11-14-2010
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
welcome... it sounds like it has to be something fuse or relay related... im assuming you checked all fuses in both panels?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New to the Forum...New to Rangers 01rangerstang03 Member Introductions 11 06-15-2010 10:03 PM
New to this forum but not new to Rangers Old97 Member Introductions 16 11-01-2009 04:11 AM
New Ranger, new to the forum, old Ranger fan... talon63 Member Introductions 13 07-07-2008 11:11 AM
Not sure if this is the right forum... problem with forum Wowak Ranger-Forums Office 6 08-04-2004 02:13 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:09 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.