No Clue. Help Please! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-30-2011
saucybeaver's Avatar
Member
Thread Starter
 
Join Date: May 2011
Location: Sparks nevada
Posts: 7
Icon4 No Clue. Help Please!

So last week i droped the trany and replace clutch and slave cylinder. My buddy cut the hydrolic line to the slave cylinder, replaced that and now my truck is barely running. When first starting the truck it runs fine and idle is normal. After driving idle is irregular and if left just running it will die on its own if not givin gas. Also when driving towards the top end of my gears when rpms are higher it acts as if not getting enough gas or full combustion and lurches. im taking it into shop in two days im wondering if theres something i did wrong with doing the clutch, or if its something minor like spark plugs that could solve the prob befor i take it in and pay out my a*# for repairs.

I have replaced fuel pump, screen and filter recently so shouldnt be that.
Reply With Quote
  #2  
Old 08-30-2011
brichmond's Avatar
Member
 
Join Date: Dec 2006
Location: IA
Posts: 116
pinched fuel line?
Reply With Quote
  #3  
Old 08-31-2011
saucybeaver's Avatar
Member
Thread Starter
 
Join Date: May 2011
Location: Sparks nevada
Posts: 7
id need to check but im pretty sure its not that if i had a pinched fuel line wouldnt i notice a difference even from start up?
Reply With Quote
  #4  
Old 09-01-2011
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Check the wires to the O2 sensor(s) See if you pinched one between the engine and bell housing.
Reply With Quote
  #5  
Old 09-06-2011
saucybeaver's Avatar
Member
Thread Starter
 
Join Date: May 2011
Location: Sparks nevada
Posts: 7
so i replaced spark plugs and darn thing took awhile but it runs alright now. but it still feels like somethins sliping in second gear could anyone tell me if this is just the clutch disc seeding itself?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Sqeaking in rear...no clue hilljack13 General Technical & Electrical 4 05-25-2013 11:19 PM
anyone have a clue about dovetailing and bobbing? silverbullet32 Fabrication & Tool Tech 50 01-09-2010 04:46 PM
ALBERTA boys clue in.. REAR disc swap Sonic_03 General Ford Ranger Discussion 16 04-25-2009 05:48 PM
umm anyone have a clue ILL BE FAMOUS 2.9L & 3.0L V6 Tech 10 01-08-2007 08:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:16 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.