OHC Map light no functioning - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
OHC Map light no functioning

i spent 5 hrs today installing the OHC today, about 2 of those hours trying to get the map lights to work. I did exactly what the instructions said, the bulbs where blackened but the filliment was not damage, but i replaced them after an 1 hr of fgihting, but still not working....can anyone help me?
Reply With Quote
  #2  
Old 10-20-2006
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
Where did you tie them in at? As far as I know, you're lacking the wires in your dome light area to tie the map lights into on an '05.
Reply With Quote
  #3  
Old 10-20-2006
04lvl2's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Palm Bay, FL
Posts: 5,600
You have to tap into different wiring for 04+, Bob will chime in I am sure. I had the same issue on mine. You have to run another wire down to the SJB.
Reply With Quote
  #4  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
i wired it right, i had to wiring into the speed sensor wire behind the gauge cluster, i teid into the dome light for the OHC, and to the dimmer
Reply With Quote
  #5  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
the temperature and direction comes up on the display, and it dims when i turn on the headlight, and dim the dash lights
Reply With Quote
  #6  
Old 10-20-2006
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
Let me ask again, and give me colors and locations: how did you wire it? What wire did you tap for the map lights? To keep saying "you wired it right" isn't going to help us diagnose your problem: either you did wire it wrong, or your OHC is broken. One we can assist with and the other we can't.
Reply With Quote
  #7  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
And i check for power coming to the map lights,they are getting power to the harness, so i am wondering something in the console itself is fried
Reply With Quote
  #8  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
I used your diagram, and the special 04+ wiriing on it, but i couldnt find the gry/blck wire in the smart junction box, someone told me last resort is behing the instrument cluster and it was
Reply With Quote
  #9  
Old 10-20-2006
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
The gray/black wire is NOT the map light wire. In my how to I tell you what each wire is for. Find the color that is supposed to be the map light power and tell us where in your truck you hooked it. The VSS wire doesn't affect the map lights.
Reply With Quote
  #10  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
Only 1 wire (blck/blue) its tired to the dome light
Reply With Quote
  #11  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
i know...just saying, it's the only location for the vss on my truck
Reply With Quote
  #12  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
and the green/orange is tied to the dimmer module
Reply With Quote
  #13  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
so maybe green/orange is different for my truck to?
Reply With Quote
  #14  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
looks sweet though...thankx for the how-to
Reply With Quote
  #15  
Old 10-20-2006
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
No problem and you're welcome -- I love mine as well, lol.

You've now posted the necessary info for someone with later truck prints to help you now. My guess is: the green/orange is not tied in to the right spot. The dimmer module isn't supposed to control that. The dimmer only has power with the key on, and generally the map lights are supposed to have "always on" power supplied.

I don't remember offhand where Bob put it, but it needs "full time" power and it should be on an appropriately fused feed.
Reply With Quote
  #16  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
I do not want to tackle your EATC install though, if i had this much trouble, i'd prolly hang myself after trying it.LOL
Reply With Quote
  #17  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
where did you tie it in at?
Reply With Quote
  #18  
Old 10-20-2006
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
Well, in my 2002, the dome light area has an "unused" wire in it for map lights. In 2001-2003 Rangers one can simply bolt in a different dome light and have map lights. There is an actual grn/orn wire in the roof that the OHC can use and it makes it easier.

In 2004 apparently the wiring harness was very revised and even some color codes changed. Bob (rwenzing) is the expert on newer Rangers pretty much. Although a mechanical engineer by training, he's analytical and precise and has refined his electrical knowledge to where it rivals mine I think, lol. Hopefully he'll help you find the right place to put your wire.
Reply With Quote
  #19  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
thankx alot, i very much appreciate it.
Reply With Quote
  #20  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
if i hooked up the gree/orange to the dome light, would i be able to test the maps?
Reply With Quote
  #21  
Old 10-20-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
I also found a a website with pdf's on owner manuals for explorer's, just to now how to recalibrate the ohc, here's the link
http://www.analogstereo.com/ford_exp...ers_manual.htm
Reply With Quote
  #22  
Old 10-20-2006
bwester04's Avatar
Member
 
Join Date: Mar 2006
Location: Round Rock, Tx
Posts: 2,641
Did you make sure it's hooked up to a good solid ground?
Reply With Quote
  #23  
Old 10-21-2006
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
For 2004+, the console's map light wire (LG/OG) should be connected to the Ranger's LG/OR which is the "Battery Saver" circuit. The LG/OG for 2004+ starts at the gray connector of the Smart Junction Box and ends at the dimming module. You can tap it at either end.

The Battery Saver circuit is hot when the key is on and remains hot for a few minutes after the key is turned off. If you tried the map lights after the BS had timed out, they wouldn't have worked. Using the BS wire could save you from a dead battery if you left the map lights on accidentally.

You could also connect the console's LG/OG to a fused constant hot. That should work fine but you would lose the Battery Saver benefit.
Reply With Quote
  #24  
Old 10-21-2006
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
Quote:
Originally Posted by 05ranger
if i hooked up the gree/orange to the dome light, would i be able to test the maps?
As a temporary test, yes. Since the map lights should light up as dome lights when the map lights are off, if you hooked it up that way and opened the door, the lights should stay on whichever way the switch is engaged. Basically, hook it up that way, and the light should be on.

Right now, when the map light switch is in the correct position, the lights should light as dome lights. Is that happening now?
Reply With Quote
  #25  
Old 10-21-2006
05ranger's Avatar
Member
Thread Starter
 
Join Date: Sep 2006
Location: Edmonton
Posts: 91
they haven't worked yet, so i will hooked green/orange to dome for testing, i hooked ground to screw on mounting plate, can't get any more of a solid ground than that
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
ABS light on - now off and functioning fine?? Bird76Mojo Drivetrain Tech 13 02-06-2011 04:26 PM
OHC Map light XeRo Interior Semi-Tech 7 06-29-2008 08:21 PM
4WD low barely functioning Jordan Drivetrain Tech 2 10-24-2007 01:17 PM
Found out why my OHC map lights dont work... jtslmn720 General Technical & Electrical 8 10-08-2007 08:10 PM
OHC Map light doesnt work jtslmn720 General Technical & Electrical 3 08-05-2007 09:52 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:20 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.