P0306, ugggggh......... - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-10-2009
Prerunner-Ranger's Avatar
Level I Supporter
Thread Starter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
P0306, ugggggh.........

So here's my p0306 issue.

This past weekend I went to barstow, on my way back I notice a decline in power and my check engine light comes on for no damn reason

So I run my scangauge and it's p0306. I call up s10killer and fddriver and they tell me that it's Cylinder 6 misfiring. I pull over at the nearest Vatozone and get a new plug. Pull over at a friends house and let my truck cool down then swap it out. All is well and I head to the casino.

Today on my way to work, check engine is back and better then ever. Running same p0306 code on my scangauge.

What should I swap next? Coil pack? Wires? The wires are only about a year old and the plugs were done about 3 months ago.
Reply With Quote
  #2  
Old 06-10-2009
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Check to make sure the wire is secure on the coil pack
Reply With Quote
  #3  
Old 06-10-2009
03bamaGT's Avatar
Member
 
Join Date: Aug 2006
Location: B'ham, AL
Posts: 1,752
Quote:
Originally Posted by 04blackedge View Post
Check to make sure the wire is secure on the coil pack
Yep...and there are no visible cracks near the connector, and check the plug itself.
Reply With Quote
  #4  
Old 06-10-2009
Prerunner-Ranger's Avatar
Level I Supporter
Thread Starter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
Will do, I'll reply with my findings.

Thanks guys.
Reply With Quote
  #5  
Old 06-10-2009
herm59's Avatar
Member
 
Join Date: Jun 2008
Location: Toms River, NJ
Posts: 1,694
Dont forget to make sure to check the whole wire as your checking the connections.
Reply With Quote
  #6  
Old 06-19-2009
Prerunner-Ranger's Avatar
Level I Supporter
Thread Starter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
Welp, changed out the coil pack with a brand new one. Still didn't fix the issue, so last on the list was wires. I went to vatozone and luckily I had them on warranty from the last time I replaced them, so I grabbed a new set for free and put them in. Reset the code.

All is well.... so far.

Thanks all!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
p0306 and p0305 wtf???? MudSlanger 2.9L & 3.0L V6 Tech 10 03-18-2009 12:56 PM
Here we go, CEL P0306 Rolldogg 2.9L & 3.0L V6 Tech 9 04-15-2008 08:25 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:50 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.