problems????? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-30-2010
Member
Thread Starter
 
Join Date: Jun 2010
Location: summerville, sc
Posts: 9
Icon5 problems?????

problems i have are i believe it idles high?? about 1500 rpms (not sure if thats right or not as im new to trucks) when im at a steady speed in any gear under 2k rpms it shutters and feels like a loss of power. i dont know how to fix those problems so if anyone knows please let me know thanks : )
Reply With Quote
  #2  
Old 07-01-2010
Member
Thread Starter
 
Join Date: Jun 2010
Location: summerville, sc
Posts: 9
oh yes i should say its a 1987 with a v6 5 speed

Last edited by xlt87; 07-02-2010 at 11:00 AM.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Clutch problems or Motor problems? Or both? JGod General Ford Ranger Discussion 3 02-08-2014 07:35 AM
Clutch problems...possibly?!?!? Help?? ZetaOmegaRanger 2.9L & 3.0L V6 Tech 2 01-04-2008 02:47 AM
Door dinger mod... now problems with blinkers? Zero General Technical & Electrical 4 09-28-2004 11:35 AM
Amp problems Skyjacker_44 Audio & Video Tech 3 08-31-2004 09:52 AM
Driver's side seat belt problems... 98blackranger Interior Semi-Tech 6 06-24-2004 02:07 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:40 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.