Amp problems - Ranger-Forums - The Ultimate Ford Ranger Resource

Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Amp problems

Reply

 
 
 
  #1  
Old 08-11-2004
Skyjacker_44's Avatar
Member
Thread Starter
Join Date: Jul 2004
Location: Hillsboro,Texas
Posts: 1,079
ok i went and bought a new amp....hooked it up yesterday to see if it was working and it was working fine.....pulled it outnlast night so i could clean up the wires and every thing....hooked it back up this morning and nothing...it's not working i'm ready to take my shotgun to this freaking thing......what should i look for to be the problem....the main thing thats throwing me off is the light that says every things fine says everythings fine......but it's still not working any ideas?
 
Reply With Quote
  #2  
Old 08-11-2004
Strider0O0's Avatar
Member
Join Date: Jul 2004
Location: Philadelphia, PA
Posts: 3,588
I'm sure you probably already checked, but ill ask anyway.. did you check your inline fuse??? if so.. how about the fuses on the amp itself??? sinse you said there's a light signaling everything is fine, or at least, on, these 2 are probably not it. same goes with your remote wire.. there'd be no light if the remote wire wasnt hooked up. what kind of amp is it?? i'm not sure if you said so or not, but is the amp for your subs?? if so.. do you have the sub wiring connected correctly?? it sounds like you have everything connected sinse you have a light on.. but maybe the sub wire itself is not connected.. check all of the amp connections, and the sub box itself..
 
Reply With Quote
  #3  
Old 08-24-2004
Member
iTrader: (1)
Join Date: Jun 2004
Location: Belleville, Il
Posts: 972
one other thing u could do is see if the wires to the subs the ones inside r connected and u could always try and hook a volt meter to the speaker wire connectors and read the ohms
 
Reply With Quote
  #4  
Old 08-31-2004
Skyjacker_44's Avatar
Member
Thread Starter
Join Date: Jul 2004
Location: Hillsboro,Texas
Posts: 1,079
i'v never thought about that i'll try that today after school
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JGod
General Ford Ranger Discussion
3
02-08-2014 07:35 AM
biketheozarks
General Technical & Electrical
5
04-08-2012 08:00 AM
Turfco
4.0L OHV & SOHC V6 Tech
5
04-21-2011 04:29 PM
dross93ranger
Audio & Video Tech
13
08-25-2006 09:44 AM


Thread Tools
Search this Thread
Quick Reply: Amp problems


Contact Us Sitemap Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.