Questions from a new(to me) ranger owner - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-19-2013
Member
Thread Starter
 
Join Date: Mar 2013
Location: Monroe, NC
Posts: 1
Questions from a new(to me) ranger owner

Hello everyone,
I have been browsing through alot these threads and have learned quite a bit already, I just wanted to see if anyone could help me out with a few things with the ranger I just bought.

-There is a wuh wuh sound which seems to be coming from the front end. I hear it most up to around 15-30 mph. Steering doesn't affect the noise whatsoever so i figure i can rule out a bad wheel bearing. i plan to take a look at it tomorrow. Just wondering if there were any common issues..

-I have the "bump" from taking off from a dead stop, and occasionally i notice it when im braking just before i come to a stop. The truck shifts fine so im pretty sure its not the trans. i bought some normal lithium grease from advanced and have learned to grease the slip yoke. I plan to grease it tomorrow. its a 2wd just wondering if there was anything i should lookout for before hand or any tips/tricks..

-The compressor on this thing. It seems to come on every 10-25 secs no matter if its heat or ac. I asked around and was told it was most likely low refridgerant. Air was already cold as s***, heat was hot as s*** so i wasnt too worried. I attempted to charge it,(while it was like 50* outside) and the compressor kept clicking dropping pressure, clicking again and a second or two later the pressure would gradually build back up. I didnt want to overcharge it so i stopped. Any Help?

-While the truck is idleing there seems to be a very slight stutter/miss. I have no check engine light, doesnt seem to affect anything just annoying. I ran some seafoam through it, hasnt changed any. Aside from changing plugs/wires etc i was wondering if there was any easy common fix for this?

-Last the power steering pump is LOUD! steering is fine,Fluid is good. I read this was common on these trucks so Im not too worried, Aside from changing fluid/vacuuming it i was wondering if there was any secret additive or trick to possible quiet it somehow..

Thank you all for any information in advance..
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Former S-10 owner now a proud Ranger owner! JPence79 Member Introductions 11 06-25-2017 08:38 AM
New Ranger owner, old Ranger - couple questions on A/C and the P1443 OBDII code Azaraith General Technical & Electrical 0 06-01-2013 09:23 PM
New Ranger owner with some 4.0 freshening up questions. chrissw_us 4.0L OHV & SOHC V6 Tech 15 08-09-2010 02:05 PM
Possible new Ranger owner here with some questions.... johnnyar General Ford Ranger Discussion 12 04-16-2009 09:59 PM
new ranger owner with a few questions x182dan General Ford Ranger Discussion 8 11-12-2006 01:08 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:01 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.