some kinda electrical prob???????? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-30-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: dallas, tx
Posts: 4
some kinda electrical prob????????

i have a 92 ranger that up untill yesterday drove fine. i went to the store came home and left it for the night. the next morn i tried to start and nothing. it has plenty of battery life. but it wont even turn over. so i checked the starter and was able to start via crossing terminals. so then i figured it was the the clutch pedal safety switch so i bypassed. dont worry was gonna replace if it was the issue. but nada. now ive noticed the horn no longer works and my amp no longer will come on but i have plenty of juice. can an ignition switch cause all of these problems or do i have an electrical gremlin. any advice would be greatly appreciated thanks yall.
Reply With Quote
  #2  
Old 08-30-2010
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
try the starter solenoid jump across it and if it starts bingo
Reply With Quote
  #3  
Old 08-30-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: dallas, tx
Posts: 4
ive done that all ready. so i guess your telling me the ignition is the next move. thanks for your help. im just confused as to what the amplifier and the the ignition switch have to do with each other. the amp is grounded and hooked up nstraight to the battery. any info on this would also be helpfull
Reply With Quote
  #4  
Old 09-03-2010
Scrambler82's Avatar
Old Guy Userů ltr
iTrader: (12)
 
Join Date: Jul 2009
Location: SoCal
Posts: 6,765
I had a ’95, 2.3L, once in a while it too would decide not to start for me…
Used to get out and shake some of the connections and then it would start.
Thinking here that we are talking about bad connections.
check out your connections clean them up and add some electrical-paste, make sure to check grounds too and the solenoid gourd especially.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
trip computer prob BigBowtie Interior Semi-Tech 0 12-24-2007 09:10 AM
Well the 07 will prob never rust.. Mark98xlt General Ford Ranger Discussion 12 10-16-2007 11:54 AM
Iridium spark plugs? AND roufgh idle prob MonsterGuy General Ford Ranger Discussion 14 06-22-2007 06:06 AM
Prob been asked before BUT????? vp6799 General Technical & Electrical 5 06-22-2005 12:12 AM
i have a 4.0L engine which is great, but i have a brake prob v698ranger 4.0L OHV & SOHC V6 Tech 5 11-02-2004 12:21 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:49 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.