Starting/Electrical issue - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-10-2011
Fenech627's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2007
Location: Detroit, MI
Posts: 908
Starting/Electrical issue

Today, upon disconnecting and removing the battery then reconnecting it back in place I ran into a problem. All my electrical worked in my truck when I turned the headlights, wipers and so fourth on. When I attempted to start my truck everything would die (truck would not start) and I would get a interference style noise coming out of my speakers. I noticed that this sound would stop if I applied the brakes. Once this happens I usually cant turn my headlights on or anything else that runs on battery power for a while.

Truck still not running

Any ideas?
Reply With Quote
  #2  
Old 04-10-2011
Toreador4x4's Avatar
Member
iTrader: (6)
 
Join Date: Apr 2007
Location: Livonia, MI
Posts: 3,958
poor connection at the battery. make sure both terminals are clean and tight and not reversed. If they are fine, put it in neutral and try to start
Reply With Quote
  #3  
Old 04-11-2011
Scrambler82's Avatar
Old Guy Userů ltr
iTrader: (12)
 
Join Date: Jul 2009
Location: SoCal
Posts: 6,773
X2 Cleam’um up, tighten’um up and put on some anticorrosion paste; not too much !
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Starting to hate my truck because of electrical issue??? NewShockerGuy General Technical & Electrical 8 10-12-2013 05:15 AM
Weird Electrical Issues Related to Starting culinandy 4.0L OHV & SOHC V6 Tech 3 10-03-2013 07:51 PM
Strange Electrical Problem When Starting 1999rangerXLT General Technical & Electrical 3 09-17-2011 06:26 PM
horrible starting, revs up after starting. smokindmax SOHC - 2.3L & 2.5L Lima Engines 5 09-01-2009 11:33 AM
Electrical issue nathan.payton General Technical & Electrical 2 11-07-2008 02:56 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:12 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.