trailer problems and out of ideas - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-05-2008
Member
Thread Starter
 
Join Date: May 2008
Location: oak harbor,wa
Posts: 4
trailer problems and out of ideas

ive got a 91 ranger and wired a new pig tail up for my new trailer which i also re-wired with new lights anyway so i wire it up and i got everything working but oddly enough when my headlights r on and i apply brakes all trailer light go out but release them and the light r back but brake light work fine without parking lights on,so i asked around and was told the connectors i used were crap and got a weak connection plus i need to have a good ground so i di away with that pig tail bought a t-connector cleaned and re connected ground on it and now still same problem all is fine except brakes when parking lights on so i hooked it up to another trailer that i know works fine and sure enough same thing so i now know its the truck trailers fine but i dont no where to start since alls i have is a t-connector good ground and i thought maybe a short somewhere but even though trailers lights go out when brakes pushed the truck lights always stay on no problems but plz help me!
Reply With Quote
  #2  
Old 05-05-2008
racsan's Avatar
Member
 
Join Date: Sep 2006
Location: central ohio
Posts: 647
first off, make sure your ground is good,( truck and trailer) most lighting problems i have ran into involved not having a good ground. ive even ran a wire from the battery ground all the way back to the pigtail before to have a good ground. if you truely have a "short" you should be blowing fuses, you may have a open circuit somewhere. after establishing a good ground, start checking things out with a test light. i did have a issue with my truck taillight fuse not being heavy enough for both the truck and trailer. if you have a "converter box" (used with 3 color tail lamps like '93 & up rangers) it may be bad, that can cause weird issues. but start with making sure of your ground first.
Reply With Quote
  #3  
Old 05-07-2008
Member
Thread Starter
 
Join Date: May 2008
Location: oak harbor,wa
Posts: 4
Alright Ty Very Much Ima Giver A Try And See What Happens
Reply With Quote
  #4  
Old 05-07-2008
Member
Thread Starter
 
Join Date: May 2008
Location: oak harbor,wa
Posts: 4
HMMM still having issues

so i did like u and manyothers said about ground was certain had to be itbut ran ground to battery and still to no prevail also did like u said about fuse maybe not big enough so i put a bigger fuse in both the trailer tow slot and brakes and turn signals slot still nothing and about the 3 way tail light on 93 and up well i have 2 so i dont know bout that but some one told me maybe some of the wires before my t-connector might be damaged and not suppling enough juice to power both trailer and truck when brakes applied and i alos noticed today im not sure if its normal or not but when trailer is connected all light become very dim including truck but if u disconnect they brightin up but if u have any other ideas id greatly appreciate them as before im out of ideas really lol thx
Reply With Quote
  #5  
Old 05-08-2008
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
Are you sure it's wired correctly. Green wire is Right turn and stop /Yellow is left turn and stop. Brown is tail/marker lights. White is ground. Make sure those colors match.
Reply With Quote
  #6  
Old 05-08-2008
Member
Thread Starter
 
Join Date: May 2008
Location: oak harbor,wa
Posts: 4
on the truck i now have a t-connector and on the trailer all is right im pretty sure but even if my trailer is wrong i also tried my truck another freinds 4 wheeler trailer that he uses frequently and it did the same thing my trialer did.thx for ur reply
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help: Lost and out of ideas! Coolant not reaching heater core! JohnnyBGood General Technical & Electrical 6 11-05-2016 04:30 PM
There's no power coming out of the trailer light plug BlackRanger04 General Technical & Electrical 4 01-30-2011 07:14 AM
Trailer or bed swap to haul quad? (bigger pic of trailer) Alon General Ford Ranger Discussion 20 12-13-2004 06:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:50 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.