Turn signals and hazard lights not flashing anymore - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-31-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: Alberta
Posts: 48
Icon5 Turn signals and hazard lights not flashing anymore

Today, my turn signals and hazard lights on my 2010 Ranger FX4 stopped flashing. Fuse or flasher module? Bought some fuses tonight....just in case....didn't see any spare fuses on the passenger side fuse panel.....PITA location for the fuses. The fuse location on the 1996 B-series is much better and easier to access.

Thanks for any help.

Dave
Reply With Quote
  #2  
Old 03-31-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
sounds like a fuse.
Reply With Quote
  #3  
Old 04-01-2011
RLong31's Avatar
The Ban Hammer
iTrader: (5)
 
Join Date: Jul 2009
Location: Monrovia, IN
Posts: 2,629
Yea, I'd look in your owner's manual. There should be a fuse diagram and it will tell you which ones to check. Check your fuses first, and if that doesn't fix it... check relays.
Reply With Quote
  #4  
Old 04-01-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: Alberta
Posts: 48
Thanks. I will check out the fuse today. If it's not the fuse, I will be contact my local Ford dealer. Only 15,000 km on the odo (9,000 miles). :(

Dave
Reply With Quote
  #5  
Old 04-01-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: Alberta
Posts: 48
Checked fuse #17....looked fine. Have an appointment with a local dealer.

Dave
Reply With Quote
  #6  
Old 04-09-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: Alberta
Posts: 48
A local dealer replaced the flasher relay today. It took awhile since the part wasn't a stock item.

Dave
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 ranger turn signals won't work! v6 4x2 all other lights and wipers work not fuse? kappesdeb General Technical & Electrical 0 07-17-2014 12:45 PM
After hazard no turn signals Thulsa Doom General Technical & Electrical 4 01-12-2013 02:39 PM
Turn signals flashing too fast FULLSCALE General Technical & Electrical 6 09-20-2012 11:16 PM
Turn Signal and Hazard Relay 01DangerRanger General Technical & Electrical 8 04-19-2012 02:57 PM
Turn Signals are acting wierd. not flashing, just staying lit jtslmn720 General Technical & Electrical 13 03-07-2008 04:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:05 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.