Turning Signal Problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-19-2009
TruckinChuck's Avatar
Member
Thread Starter
 
Join Date: Mar 2008
Location: Chapel Hill, NC
Posts: 5
Turning Signal Problem

So just this morning, there was a bit of a fog...
and then my left tail light signal quit working. I first noticed that the indicator light on the dash was blinking very fast and my first thought: "my tail light is out". But looking at the bulb, both filaments are intact and once the fog cleared and the sun was bright and high in the sky, the signal was working fine. The indicator in the dash was fine and the bulb actually worked.

But, it started to rain in the late afternoon...
and the signal in the left rear quit working again and the indicator in the dash was blinking fast again.

I do have a hitch cover that lights up "FORD" when you hit the brakes, but I disconnected it and the light still does not work.

Only rarely does the turn signal work in the rain, but only for a second.

So, bad bulb or moisture?

Specs:
06 FX4 Level II
45K miles
All stock
Reply With Quote
  #2  
Old 03-19-2009
offroadn_redneck's Avatar
Member
 
Join Date: Feb 2009
Location: San Antonio, TX
Posts: 776
Id say that the moisture is causing a short in the circuit. Try water proofing it as much as possible with tape and what have you, and then hose it down nice and good and see if it fixes it.
Reply With Quote
  #3  
Old 03-19-2009
Member
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
replace the bulb..1.00$ FTW if it doesnt fix it your looking for a moisture problem, somethings "shorting" it out and not letting it work, or if you really want..

using the bulb that wont work, unplug it, grab a test light and leave your signal on, put the test light on either pin and if it lights up on one and flashes its working at the connector and the bulb is toast..NOW if it doesnt work then the problem could be farther down the line..check the wiring..not that hard to find might have to play detective!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Reverse Signal & Parking Break Signal brainbox General Technical & Electrical 5 06-14-2017 08:24 AM
Strange problem - engine bogs/dies when turning.. Bird76Mojo General Technical & Electrical 9 10-02-2012 05:46 PM
Best Way to Seal Turning Signal Bulbs Jelly's Ford General Ford Ranger Discussion 8 09-09-2011 12:30 PM
turn signal/heater problem? smcasey88 General Technical & Electrical 3 02-24-2010 09:17 AM
Left turn signal problem Dieseltechy360 General Technical & Electrical 4 02-23-2010 06:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.