Weird Electrical Issues. Any help will be great! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-04-2014
Member
Thread Starter
 
Join Date: Aug 2014
Location: Savannah
Posts: 2
Weird Electrical Issues. Any help will be great!

I have an 05 Ranger, 4.0 V6. Never had any problems until last night. I went to go to the store and when I turned on my lights, my horn sounded off and would not stop until I turned off the light switch. Then I noticed the park lights and instrument lights would not turn off until I disconnected the battery.

This morning I went out and found that when I attempt to blow the horn, (I did remove the fuse to the horn last night) the wipers turn on. On top of that, now when I turn on the headlights/park lights, the wipers and the wiper-washer motor turns on and the park lights stay on.

There are no electrical modifications or add-ons. The radio is stock, no lights added and no trailer was plugged in to the tow kit (factory installed).

I figure the only thing it could be is what all the components would have in-common; the ECU???

Any advice would be great before I start throwing good money after bad on the wrong things.

Thanks in advance
Dan
Reply With Quote
  #2  
Old 08-04-2014
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
These circuits all have one thing in common, the Smart Junction Block. Its located on the passengers side integrated into the fuse box.I believe the SJB also took over the function of the GEM. Others have had similar issues related moisture build up on the circuit board. Check for possible water leaks behind the kick panel in and around the SJB.
Reply With Quote
  #3  
Old 08-05-2014
Member
Thread Starter
 
Join Date: Aug 2014
Location: Savannah
Posts: 2
It did rain here real bad saturday night. Maybe it just needs to dry out. Thank You for the info. I will look for water intrusion.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Weird Electrical Issues Related to Starting culinandy 4.0L OHV & SOHC V6 Tech 3 10-03-2013 07:51 PM
weird Electrical connector undead455 General Technical & Electrical 4 12-22-2010 08:37 AM
some weird electrical probs??? please help lonestar27 General Technical & Electrical 0 08-30-2010 08:14 PM
Really Weird Electrical Problem Mitch_71 General Technical & Electrical 5 03-07-2010 01:46 PM
Weird electrical issue uhittheuglytree General Technical & Electrical 2 02-19-2010 03:07 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:46 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.