Weird electrical issue - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-19-2010
Member
Thread Starter
 
Join Date: Dec 2009
Location: Dunlevy Pa
Posts: 18
Weird electrical issue

I have a 2005 4.0 4x4. With the head lights off everything works normal. However, when I turn the headlights on the brake lights stay bright as if im on the brake, including the third brake light being on. I thought about a bad switch BUT the left turn signal does not work when the headlights are on either. The arrow on the dash just lights up and stays on. Any ideas? The only thing I have done to the truck in the past year is the fog light mod a few months ago. Making it so the fogs stay on with the high beams. I'm going to try to reverse it back to stock to see if that helps. Do any of you guys have any ideas?
Reply With Quote
  #2  
Old 02-19-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
The left brake light bulb is probably shorted inside or the socket.
Also check the wires and plug for the factory trailer light harness.
Reply With Quote
  #3  
Old 02-19-2010
Member
Thread Starter
 
Join Date: Dec 2009
Location: Dunlevy Pa
Posts: 18
I actually got it fixed right after I posted that. I went out and started fooling around and found the trailer harness to be shorted. All the salt and ice just corroded the crap out of it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
AC Works/Doesn't? Weird electrical problem?... aaronspriggs General Technical & Electrical 4 07-14-2012 07:18 PM
Weird electrical problem. reader585 General Technical & Electrical 3 04-19-2011 01:04 PM
weird Electrical connector undead455 General Technical & Electrical 4 12-22-2010 08:37 AM
some weird electrical probs??? please help lonestar27 General Technical & Electrical 0 08-30-2010 08:14 PM
Really Weird Electrical Problem Mitch_71 General Technical & Electrical 5 03-07-2010 01:46 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:31 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.