Weird Problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-17-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: Killeen, TX
Posts: 3
Icon11 Weird Problem

2003 Ranger,4 Cylinder, 2WD-72,000 miles

I was making an 800 mile drive recently and noticed a strange problem WHen cruising at highway speeds and going uphill the truck would sort of hic-up. No noticable difference in noise but it would sort of jerk. When I downshifted to 4th at rapped it out, no jerk. This went on until I reached my destination. Driving around town, no problems.

On the return trip home I had the same problem. This time I also noticed it under hard acceleration trying to merge into traffic. Whenever I tried to go uphill, same thing. The problem became more frequent the longer I traveled.

Now driving arount town, no problem. Placing any sort of load on the drivetrain, the jerky hic-up happens.

Things I have tried: Code Reader-No Failures, replaced gas, fuel filter, utilized 2 doses of fuel injector cleaner, new spark plugs, new wires.

Any ideas?

Last edited by kendawg; 03-17-2012 at 01:07 PM.
Reply With Quote
  #2  
Old 03-17-2012
Member
 
Join Date: Jun 2005
Location: Havertown,PA
Posts: 467
Has your timing belt been replaced? My escort gets that way before its ready to break. The Escort goes at 50K. Not sure the recommended milage to replace Ranger 4 cylinder.
Reply With Quote
  #3  
Old 03-17-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: Killeen, TX
Posts: 3
Quote:
Originally Posted by BigEdge126 View Post
Has your timing belt been replaced? My escort gets that way before its ready to break. The Escort goes at 50K. Not sure the recommended milage to replace Ranger 4 cylinder.
My engine has a chain instead of a belt. They are not known for breaking. There is not set replacement schedule.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
stumped...weird headlight problem wvcat General Technical & Electrical 12 08-29-2008 01:05 PM
Weird idle problem when putting truck in neutral coming to stops. Jeremy102579 2.9L & 3.0L V6 Tech 13 03-25-2007 10:26 AM
Weird Brake Problem? Roach2004 General Ford Ranger Discussion 11 03-20-2007 10:55 PM
weird radio problem, please help TippnOver General Technical & Electrical 12 12-03-2005 04:44 PM
Weird brake problem... Zero Drivetrain Tech 3 06-05-2005 02:00 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:15 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.