What the &^#$!@ happened to my turn signals??? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-12-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
What the &^#[email protected] happened to my turn signals???

So I hop in my truck yesterday to make my trip to Doc's house. I start the truck and was about to pull out when I realized I had no turn signals. My fourways work. I pulled the fuses, even Doc checked it out with the fuse tester. Since the left and right have their own fuse I wouldn't imagine it'd be a fuse anyway. There is no relay clicking, neither indicator lights work, turn signal doesn't flash on the exterior. I checked the owners manual for a relay under the hood or something, no luck. I can hear the four way relay behind the dash. I'm thinking it's the switch or something behind the dash. Like I said four ways work perfect. I'm tired of ppl looking at me like I'm an idiot, I use my turn signals religiously and feel like an *** "cutting ppl off" lol Doc said use hand signals but I'm not so sure if many ppl would know what I'm doing.

I don't want to take it to the dealer, I have way to much warranty voiding stuff going on behind there =\. What's my next step? Thanks guys!!
Reply With Quote
  #2  
Old 06-12-2006
HAZZARDJOHN's Avatar
Member
 
Join Date: Dec 2005
Location: Wyoming MN
Posts: 2,400
Check the Flasher for the turn signals. There are two flashers, one for the Turn signals and one for the four ways, so it is possible for the signal flasher to be out, and the four ways to still work.

~HJ
Reply With Quote
  #3  
Old 06-12-2006
RockysFord's Avatar
Member
 
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
More than likely the flasher.....F350 at work did the same thing..4 ways worked but no turn signals....


Sounds to me like you need to get rid of the truck, lmao....problem after problem...

Rocky
Reply With Quote
  #4  
Old 06-12-2006
winks's Avatar
Member
iTrader: (5)
 
Join Date: May 2005
Location: Jackson, New Jersey
Posts: 4,872
Do your windshield wipers and high beams work? Maybe its a problem with the lever on the column.
Reply With Quote
  #5  
Old 06-12-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
I'm gonna go check the highbeams and wipers right now. Where is the flasher located guys? Behind the dash?

Quote:
Originally Posted by RockysFord
Sounds to me like you need to get rid of the truck, lmao....problem after problem...

Rocky

Tell me about it!!!

26k miles and somedays I'd rather drive it off a cliff than fix it.
Reply With Quote
  #6  
Old 06-12-2006
buckgnarly's Avatar
Member
iTrader: (11)
 
Join Date: Jan 2005
Location: West Topsham, VT
Posts: 1,709
I know on mine you sometimes have to adjust the tilt up and down to make it work. There are some positions that the turns will not work, but usually playing with it brings them back.
Reply With Quote
  #7  
Old 06-12-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
All good ideas, thanks guys!
Reply With Quote
  #8  
Old 06-12-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
Same thing happend to me. It was the turn signal flasher for me, its located under the steering wheel behind that knee panel. You can get to it by crawling under where your pedals are and looking up. Its cramped, but doable. I think it cost me lik $8 for a new one. Its easy to do.
Reply With Quote
  #9  
Old 06-12-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
Yeah I just tryed to moved the tilt steering...nothing. I tryed the hig beams and wipers, they work. So I guess I'll have to get the flasher unit. You wouldn't have the part# off hand would you? Can I get this from an auto parts store or do I have to call the dealer?
Reply With Quote
  #10  
Old 06-12-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
no stealership run needed...let me run out and pull it real quick and ill get you the numeros
Reply With Quote
  #11  
Old 06-12-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
OK Travis, Here is what mine said. Its Ford Part #F678-13350-AA . Im pretty sure I picked it up at napa, but this happened to my rig like 2 years ago so i dont really remember....but im sure with that part # any auto repair place will beable to point you in the right direction....BTW its located directly above your hood release cable pretty much centerline of your knee plate. To remove it you just slide the flasher towards the passangers side and disconnect the harness. reinstall and your done.
Reply With Quote
  #12  
Old 06-12-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
Quote:
Originally Posted by Kanoeking
OK Travis, Here is what mine said. Its Ford Part #F678-13350-AA . Im pretty sure I picked it up at napa, but this happened to my rig like 2 years ago so i dont really remember....but im sure with that part # any auto repair place will beable to point you in the right direction....BTW its located directly above your hood release cable pretty much centerline of your knee plate. To remove it you just slide the flasher towards the passangers side and disconnect the harness. reinstall and your done.
Thanks bro! I'll go out and verify the part #'s since I know where it's at now. I thought I was gonna have to remove the dash. Oh well, I can change the gauge colors another day =]
Reply With Quote
  #13  
Old 06-12-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
Did i say that you didnt have to tear the dash apart....i mean yeah you have to remove all of those pesky t-15's and take the gauge cluster out and change the color and then you will be granted the access code to get to the flasher....did that help?!

Oh one more thing that might help, is that its bright **** yellow!
Reply With Quote
  #14  
Old 06-12-2006
RangerEdge17's Avatar
Member
 
Join Date: Mar 2006
Location: NY
Posts: 58
yes its a pain in teh *** too do, but once you do it once it won't be soo hard the next time you do it
Reply With Quote
  #15  
Old 06-13-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
When I'm at a complete stop if I hit the switch just right I can make it blink lol. Otherwise it just stays on.
Reply With Quote
  #16  
Old 06-13-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
And youve replaced the flasher?
Reply With Quote
  #17  
Old 06-13-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
no no no, when i found out what I needed all the local auto parts places closed a few mintues earlier. I didn't wanna drive 45 minutes to get a $8 part lol. Woulda cost the same in gas. I'm about to go out right now to get it.
Reply With Quote
  #18  
Old 06-13-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
Nice...i was gonna say...well then my friend you gonna need to take a peek at your multi switch for your H beams, water clearing apparatus, blinky actuator, and blue water sprinkler maker!
Reply With Quote
  #19  
Old 06-13-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
ok i could not find the yellow box. i turned on my four ways and the clicking was coming from a big black plastic box under the dash. I gotta clip some wire ties to open the big box. They're in the way of opening the it. ugh...hopefully it's in there.
Reply With Quote
  #20  
Old 06-13-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
Your 4 way box and your blinker flasher are seperate... hang on a sec and ill go snap a quick pic and post it....just dont clip any thing and or pull anything apart yet...youll thank me later!
Reply With Quote
  #21  
Old 06-13-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
Upon further inspection, I guess the 4 ways and the blinkers are on the same flasher, just different terminals of that flasher. But here are some quick pics of what your looking for. Yours might be black, i think my stock one was.
Name:  fix005.jpg
Views: 28
Size:  14.5 KB
Name:  fix006.jpg
Views: 356
Size:  17.7 KB
Reply With Quote
  #22  
Old 06-13-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
The part # you gave me was the same part just a dif number for my model year (ford genius's). It was blue though btw and encased in a big black housing with 4 other small black relays. I just got back from the dealer with a new one and it doesn't work. Luckily I tryed it in the parking lot. I got a refund and scheduled an appt for tomorrow. Hopefully the extended warranty picks up some of the cost. Pretty damn sh1tty. I just hope they don't f* up any of my wiring. I've got as much wiring under there if not more than ford put there from factory lol.
Reply With Quote
  #23  
Old 06-13-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
EEEEEEKKKKKK.....what has ford been up too on that one!?!
Reply With Quote
  #24  
Old 06-13-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
I dunno man. I'm getting pretty pissed off though. I'm about to go trade this sucker in.
Reply With Quote
  #25  
Old 06-13-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
AHHHH! Dont say that! Tell me you didnt mean it!!!! TELL MEEEEEE!!!!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
turn signals & flasher clifpayne General Technical & Electrical 0 09-26-2010 02:40 PM
Checking Interest: OEM Headlights & Turn Signals '96 Era, KY buggman Interior, Exterior, Electrical, & Misc. 0 06-29-2010 11:51 PM
turn signals are really really fast quicksilver2001 General Technical & Electrical 18 01-29-2006 02:23 PM
Slowing down LED bulbs in the turn signals Mnemonic General Technical & Electrical 5 06-12-2004 08:12 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:23 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.