Wipers and blower motor only work on high. - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-08-2012
Member
Thread Starter
 
Join Date: Apr 2012
Location: Topsfield, Ma
Posts: 6
Wipers and blower motor only work on high.

Like the title says, my wipers only work on high and stay where they are when I shut them off. I called the dealership and the ("new and improved part, original was discontinued") lists at $330.

Also the blower moter only works on high.

Any ideas? 1992, intermitent wipers, no A/C.

Thanks,
Joe.
Reply With Quote
  #2  
Old 04-08-2012
FULLSCALE's Avatar
Level III Supporter

iTrader: (12)
 
Join Date: Mar 2009
Location: Clinton, Ontario
Posts: 8,181
Did both problems start at the same time? Usually when the blower motor only works on high it's the blower motor resistor.
Reply With Quote
  #3  
Old 04-08-2012
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Quote:
Originally Posted by The Chef View Post
Like the title says, my wipers only work on high and stay where they are when I shut them off. I called the dealership and the ("new and improved part, original was discontinued") lists at $330.
Check the multifunction switch operation

Quote:
Originally Posted by The Chef View Post
Also the blower moter only works on high.
Check the blower motor resistor and or connector
Reply With Quote
  #4  
Old 04-08-2012
FULLSCALE's Avatar
Level III Supporter

iTrader: (12)
 
Join Date: Mar 2009
Location: Clinton, Ontario
Posts: 8,181
Quote:
Originally Posted by Rev View Post
Check the blower motor resistor and or connector
Forgot about the connector... they have a bad habit of getting hot and melting!
Reply With Quote
  #5  
Old 04-09-2012
Member
Thread Starter
 
Join Date: Apr 2012
Location: Topsfield, Ma
Posts: 6
I bought the truck about three weeks ago. It came to me with these issues. I figured I would just get a new wiper switch, but the stupid thing costs an arm and a leg ($330 from Ford). I've been to a few bone yards but none of them have any 92s or older. Could it be as simple as a relay and can the switch be pulled apart and cleaned, or do you have to replace them when they give you trouble.

I pulled the heater resistor out and it's pretty corroded, so I'm gonna guess that's it. However, the connector is stuck together so that is another issue. I've never owned anything this new, so all this electrical diagnosing stupidity is somewhat new to me, wires going everywhere and whatnot.

I bought a Haynes manual, cause I was at Autozone instead of NAPA. The Haynes manual gives very little info about the 1992, (wiring diagrams and what-not), as well as very little info about the 3.0L engine.

Thanks,
Joe.
Reply With Quote
  #6  
Old 04-09-2012
Member
 
Join Date: Oct 2011
Location: Michigan
Posts: 347
Get the parts from RockAuto... much, much cheaper than the dealer, even Motorcraft branded parts there are cheaper there as well. All of the brands they stock are good ones, so all you really gotta do is find what you need, and pick what you prefer.

The connector won't come apart easily because the terminals are rusted together... mine was melted badly as well. It took a lot to get that thing disconnected.

What I did is seal the back of the new connector with RTV to keep **** from getting into there... one place where a GM Weathertight connector would be very beneficial, as it is pointing the back of the connector towards the front of the truck, open to receive water, dirt, and crap like that. Unfortunately, they gave us the open back connector...

As for the wipers, I have a weird issue with them as well... when they are switched on, they will wipe consistently for a bit, then not wipe at all for a little bit. (not talking about the delay... it'll go wipe, pause, wipe, pause, wipe, pause, pause, pause, wipe, pause, wipe...)

It'll do it unless you have it on the full speed 'wipe the hell outta the windshield' settings. Also, the wiper arms are a little loose. Gotta tighten that up.

Well folks, out I go to fix that exhaust leak behind the cats, and inspect them as well. If they are starting to plug up or are plugged, off they come... (gotta love Michigan!)
Reply With Quote
  #7  
Old 04-09-2012
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Quote:
Originally Posted by The Chef View Post
I bought the truck about three weeks ago. It came to me with these issues. I figured I would just get a new wiper switch, but the stupid thing costs an arm and a leg ($330 from Ford). I've been to a few bone yards but none of them have any 92s or older. Could it be as simple as a relay and can the switch be pulled apart and cleaned, or do you have to replace them when they give you trouble.
Before you buy a new wiper control module, I'd try and find a used multifunction switch. Ref Click Link

Quote:
Originally Posted by The Chef View Post
I pulled the heater resistor out and it's pretty corroded, so I'm gonna guess that's it. However, the connector is stuck together so that is another issue. I've never owned anything this new, so all this electrical diagnosing stupidity is somewhat new to me, wires going everywhere and whatnot.
Blower Motor resistor and connector Click Link
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Will this blower motor resistor work on my B3000 dogfish246 General Ford Ranger Discussion 2 08-12-2014 05:31 PM
94 ranger turn signals won't work! v6 4x2 all other lights and wipers work not fuse? kappesdeb General Technical & Electrical 0 07-17-2014 12:45 PM
ABS light on and I can't turn the speed up on my blower motor BlackRanger04 General Technical & Electrical 12 12-21-2010 11:41 AM
wipers only work in high johnh General Technical & Electrical 4 07-13-2010 11:31 AM
wipers only work on high johnh General Ford Ranger Discussion 4 07-11-2010 12:55 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:33 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.