wipers only work in high - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-10-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: Perkasie Pa.
Posts: 21
wipers only work in high

Rained today, wipers work only in high speed no low or variable, fuses all good. Possibiltys of what could be the problem. Thank you
Reply With Quote
  #2  
Old 07-10-2010
jtfoxman's Avatar
Member
 
Join Date: Jun 2005
Location: The Poconos
Posts: 891
Wiper motor may be on its way out, or just your wiper control lever. Other things also but I'll let someone else chime in who knows more.
Reply With Quote
  #3  
Old 07-11-2010
jason_ee's Avatar
Member
 
Join Date: Sep 2008
Location: Cincinnati, OH
Posts: 42
I'd check the wiper relay first, then try this fix for the lever:
Intermittent (Phantom) Windshield Wiper Fix
Reply With Quote
  #4  
Old 07-11-2010
buggman's Avatar
Member
iTrader: (38)
 
Join Date: Apr 2007
Location: Dougal County
Posts: 1,648
Possibly that multi-function switch going bad.

Mine started giving me problems a while back, sometimes the turn signals would work, sometimes not, wipers only worked when it was hot, sunny and DRY...never worked when it rained.
I finally broke down & replaced the multi-function switch and no problems with it since.

If cleaning the contacts in the push button end don't work, just remove the entire switch ***'y and clean all the connections with alcohol & water on a Q-tip, maybe even shoot some WD-40 in there afterwards for good measure.
Reply With Quote
  #5  
Old 07-13-2010
Topdog2007's Avatar
Level I Supporter
iTrader: (2)
 
Join Date: Aug 2009
Location: Blairsville, Ga
Posts: 466
Same thing happened with my sisters 1998 Explorer...if all the above fixes don't work than its the wiper motor....swapped another from a Ranger in hers and the wipers work fine now.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 ranger turn signals won't work! v6 4x2 all other lights and wipers work not fuse? kappesdeb General Technical & Electrical 0 07-17-2014 12:45 PM
Wipers and blower motor only work on high. The Chef General Technical & Electrical 6 04-09-2012 10:47 AM
wipers only work on high johnh General Ford Ranger Discussion 4 07-11-2010 12:55 PM
wipers, speedo, and odometer dont work littlered General Technical & Electrical 29 09-08-2009 11:03 PM
winshield wipers wont work Fordracer302 General Technical & Electrical 2 12-02-2007 04:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:39 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.