Hello from Mass. - Ranger-Forums - The Ultimate Ford Ranger Resource


Member Introductions New to Ranger-Forums.com? Please take a moment and introduce yourself.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-07-2012
Member
Thread Starter
 
Join Date: Jan 2012
Location: Hingham,Ma
Posts: 2
Icon5 Hello from Mass.

I bought a 2002 XLT over the summer. Had 96k on it. Factory tonneau cover, great shape body wise.Only mechanical problem i have is a leaky axle seal on the drivers side. Doesn't look too difficult to fix. Anyone done one? Also i want to change the plugs but it's the 4.0 six and the last plug on the passenger side looks like a problem to get to. Do i have to go from underneath? Any help would be greatly appreciated.
Reply With Quote
  #2  
Old 01-07-2012
Taylor's Avatar
Ive been dubbed....an old volk
iTrader: (18)
 
Join Date: Mar 2010
Location: Nashville, NC
Posts: 7,110
Welcome to RF!

That axle seal shouldne be a difficult fix.

The plugs have always been a pain to get to lol. Have you tried taking the front tires off while attempting to change the plugs?
Reply With Quote
  #3  
Old 01-07-2012
98liftedranger's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2008
Location: California
Posts: 12,538
Welcome to the site!
Reply With Quote
  #4  
Old 01-07-2012
Member
Thread Starter
 
Join Date: Jan 2012
Location: Hingham,Ma
Posts: 2
No i haven't attemted to change them yet.The other five don't look to be too difficult. I spent 10 minutes just looking at the 6th one.LOL. I'm not going to change the others if i can't get that one. Thanks
Reply With Quote
  #5  
Old 01-07-2012
KLC's Avatar
KLC KLC is offline
RF Veteran
iTrader: (29)
 
Join Date: Nov 2007
Location: New Mexico
Posts: 13,115
Welcome to Ranger-Forums!
Reply With Quote
  #6  
Old 01-07-2012
FULLSCALE's Avatar
Level III Supporter

iTrader: (12)
 
Join Date: Mar 2009
Location: Clinton, Ontario
Posts: 8,181
Welcome to the site!
Reply With Quote
  #7  
Old 01-07-2012
Rick-RF's Avatar
OG
iTrader: (1)
 
Join Date: Mar 2009
Location: Canada
Posts: 1,534
Welcome to the site!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Mass Air flow sensor mod ??? markw_06 2.9L & 3.0L V6 Tech 17 04-14-2013 01:59 AM
Hello From Central Mass XFR_Jay Member Introductions 4 11-15-2007 06:10 PM
Mass Air Flow problem, little help please... pushdeck General Technical & Electrical 10 03-18-2007 10:52 AM
Mass Airflow Sensor change RangerJustin 2.9L & 3.0L V6 Tech 2 03-16-2005 03:28 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:15 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.