Whats goin on guys - Ranger-Forums - The Ultimate Ford Ranger Resource


Member Introductions New to Ranger-Forums.com? Please take a moment and introduce yourself.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-14-2008
Ford04Ranger4.0's Avatar
Member
Thread Starter
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Icon5 Whats goin on guys

Well I'm new to this but I have a major problem with my Ranger. Driving around 40- 50 mph the truck thumps. The tach doesnt spike check the lugs and axle bolts, everythign is tight. Its an 04 auto. with 36,000 miles. I did the trans. filter at 35,000 becuse I had the problem then also. Any ideas?
Reply With Quote
  #2  
Old 12-14-2008
Machine090767's Avatar
RF Veteran
 
Join Date: May 2006
Location: Minnesota
Posts: 6,410
welcome to R-F, Mark!
Reply With Quote
  #3  
Old 12-14-2008
Jazz921's Avatar
Member
iTrader: (2)
 
Join Date: Sep 2007
Location: Evansville, IN
Posts: 997
Welcome. My first though was driveshaft. Can you describe it a little more?
Reply With Quote
  #4  
Old 12-14-2008
Ford04Ranger4.0's Avatar
Member
Thread Starter
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Its like hitting a speed bump but doing 40- 50 mph but its only at high speeds I dont feel the thump lower then 40mph. Liek i said teh tack doesnt rise and engine doesnt rev. I've asked other people with the same year Ranger thats a 4X4 and many more miles and theres shift smooth. So idk what it is.
Reply With Quote
  #5  
Old 12-14-2008
Gallo75's Avatar
Member
 
Join Date: Sep 2008
Location: Mexicali Baja California,
Posts: 456
Can't tell about your problem but welcome!

oh and
Reply With Quote
  #6  
Old 12-14-2008
Yellow_edge_4x4's Avatar
Member
 
Join Date: Oct 2008
Location: Bryan, OH
Posts: 723
are you in 4wheel drive...cuz mine dose that too somtime in 4wheel drive too
Reply With Quote
  #7  
Old 12-14-2008
Ford04Ranger4.0's Avatar
Member
Thread Starter
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Tell you the truth its all the time in 2wd or 4wd
Reply With Quote
  #8  
Old 12-14-2008
Yellow_edge_4x4's Avatar
Member
 
Join Date: Oct 2008
Location: Bryan, OH
Posts: 723
mmm idk then sorry....cuz mine only dose it in 4 wd...and with New york snow i dont need my 4x4 to sh*t on me
Reply With Quote
  #9  
Old 12-14-2008
Ford04Ranger4.0's Avatar
Member
Thread Starter
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Same here but I'm thinking it has to do with the over drive since its low rpms and a higher speed
Reply With Quote
  #10  
Old 12-14-2008
mossyoak03's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2006
Location: Virginia Beach, VA
Posts: 193
welcome to RF
Reply With Quote
  #11  
Old 12-15-2008
jaysinpa's Avatar
Member
 
Join Date: Mar 2008
Location: New Brighton, PA
Posts: 648
Welocme to the R-F club!
Reply With Quote
  #12  
Old 12-15-2008
cchsbuzz19's Avatar
Member
iTrader: (5)
 
Join Date: Jul 2007
Location: North Canton, Ohio
Posts: 2,417
is it a constant thump at those speeds?

Welcome to R-F
Reply With Quote
  #13  
Old 12-15-2008
Ford04Ranger4.0's Avatar
Member
Thread Starter
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
No, thats what I dont understand, I added Lucas Trans additive for slip, going to see if that'll work
Reply With Quote
  #14  
Old 12-15-2008
TommyC's Avatar
Member
iTrader: (1)
 
Join Date: Jun 2006
Location: CA
Posts: 1,012
Welcome
Reply With Quote
  #15  
Old 12-15-2008
Ford04Ranger4.0's Avatar
Member
Thread Starter
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Ok I just asked a buddy about it and he says its the DPFE sensor. Its about $100, I guess its a diff. ressure sensor and they fill with carbon witch makes them skip.
Reply With Quote
  #16  
Old 12-15-2008
Motorcraft's Avatar
Member
 
Join Date: Jul 2005
Location: Franklin MA
Posts: 240
welcome the DPFE sensor is only 25 bucks
please dont pay 100 bucks for it. they are cheap and very easy to install its located right behind the EGR vlave attached to the drivers side valve cover. i just replaced mine.
Reply With Quote
  #17  
Old 12-15-2008
Ford04Ranger4.0's Avatar
Member
Thread Starter
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Alright a buddy just told me to replace that. Whats wierd is that I found it and its not even mounted to anything no screws, brackts or anything and I've had this truck since new. The only thing he told me was to buy a FOMOCo. one
Reply With Quote
  #18  
Old 12-16-2008
Ford04Ranger4.0's Avatar
Member
Thread Starter
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Can you clean this PDFE??
Reply With Quote
  #19  
Old 12-17-2008
Sea-Bass's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2008
Location: Georgia
Posts: 1,059
If you bought the truck new and you have just reached 36,000 miles why havnt you taken the truck back to Ford for warranty work?? Even if the truck is just over 36,000 miles some Ford dealers will still do the work under the warranty from what I have heard, but If this was a problem before 36,000 miles I still dont understand why you didnt take it back to Ford though. I'm not bashing on you, just confused.
Reply With Quote
  #20  
Old 12-17-2008
herm59's Avatar
Member
 
Join Date: Jun 2008
Location: Toms River, NJ
Posts: 1,694
Welcome aboard. Another one from NY, too bad your upstate.

Now lets see some pics of that truck!
Reply With Quote
  #21  
Old 12-17-2008
Ford04Ranger4.0's Avatar
Member
Thread Starter
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Quote:
Originally Posted by Sea-Bass View Post
If you bought the truck new and you have just reached 36,000 miles why havnt you taken the truck back to Ford for warranty work?? Even if the truck is just over 36,000 miles some Ford dealers will still do the work under the warranty from what I have heard, but If this was a problem before 36,000 miles I still dont understand why you didnt take it back to Ford though. I'm not bashing on you, just confused.
They said they'd take it to a local tranny shop and have them tear teh whole tranny apart and make me pay for the labor. The tranny shop is know for hack jobs. So I bought the part myself which was a steal $60 for a FoMoCo one
Reply With Quote
  #22  
Old 12-20-2008
Trigger01's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Oct 2005
Location: Knoxville, TN
Posts: 18,788
Howdy hombre!
Reply With Quote
  #23  
Old 12-21-2008
Bentley's Avatar
Member
 
Join Date: Aug 2005
Location: Billings MT
Posts: 1,722
welcome to the site.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Hows it goin guys? zfromvan Member Introductions 3 05-05-2010 08:50 PM
whats goin on striker4 Member Introductions 28 02-05-2010 02:07 AM
This is a very detailed description of whats goin on...a miss-fire!!! sam0330 2.9L & 3.0L V6 Tech 4 12-21-2009 04:31 PM
whats goin on everyone, opinions please! quicksilver2001 General Ford Ranger Discussion 20 01-16-2008 06:18 AM
goin up or down.... TippnOver New Ideas 50 02-24-2005 06:36 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:47 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.