AVM INSTALL............COMPLETE - Ranger-Forums - The Ultimate Ford Ranger Resource


Snapshots Share photos of vehicles in this sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-02-2009
RangerNVS's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2005
Location: Temple, TX
Posts: 1,341
AVM INSTALL............COMPLETE

Well I finally got some projects done that I desperatley needed attention, one of which was my AVM hub install. Here's a couple of pics for ya!



My Helper:









Reply With Quote
  #2  
Old 08-02-2009
Ford04Ranger4.0's Avatar
Member
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Looks good
Reply With Quote
  #3  
Old 08-02-2009
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Sweet!
Reply With Quote
  #4  
Old 08-02-2009
Off-roadranger04's Avatar
Member
iTrader: (2)
 
Join Date: Nov 2008
Location: Newark, Delaware
Posts: 1,751
dig the truck...
Reply With Quote
  #5  
Old 08-02-2009
RangerExtreme's Avatar
Member
iTrader: (4)
 
Join Date: Nov 2007
Location: Robinson, Pa
Posts: 2,047
looks great man now you get to jump out and and lock em in
Reply With Quote
  #6  
Old 08-03-2009
RangerNVS's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2005
Location: Temple, TX
Posts: 1,341
yeah but at least I know that I'll have 4wd...no more guessing "are they locked in?" "Does my 4wd work?"......long pause........"Ummmm yeah based on the fact I'm now more stuck than I was before, my front hubs are not locked in?"

Those phrases are now a memory.....only thing I have to worry about letting go is the shift motor.
Reply With Quote
  #7  
Old 08-03-2009
Metro55's Avatar
Member
 
Join Date: Apr 2009
Location: Winnipeg
Posts: 938
manual hubs FTMFW
Reply With Quote
  #8  
Old 08-03-2009
chainfire's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2007
Location: Mission B.C.
Posts: 3,126
Man your garage is soooo clean lol. I wish mine looked like that lol.

I need a set of those bad!
Reply With Quote
  #9  
Old 08-03-2009
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
sweet! where is the rear glass?
Reply With Quote
  #10  
Old 08-04-2009
RangerNVS's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2005
Location: Temple, TX
Posts: 1,341
Andy....hahahah in my backyard collecting dust....(honestly) LOL After moving into a new house, and having a new baby my "ranger time" has been tied up. BUT that is going to change....I hope to work on them this weekend. And yes I'll take plenty of pictures for ya. I plan on doing a write up on it. I think it will help other people to know that these bedsides ( might be just my set) are way out on alignment. So it's going to take some work....but I'm tired of lookin at em....so soon...young padwan....

Jeff: yeah I've had to work hard on that part....I'm going to loose my garage here for 4 days, cause I'm sealing the concrete with quickcrete garage sealer....probabley "Ford" blue with those no-skid white and black decorative flakes....then It'll look good. heheheheh
Reply With Quote
  #11  
Old 08-04-2009
venom97's Avatar
Member
iTrader: (2)
 
Join Date: Apr 2008
Location: peking
Posts: 379
Quote:
Originally Posted by Metro55 View Post
manual hubs FTMFW
x2 been through that too with the auto hubs
Reply With Quote
  #12  
Old 09-24-2009
Member
 
Join Date: Nov 2006
Location: Dublin, GA
Posts: 23
looks good!
Reply With Quote
  #13  
Old 09-24-2009
SHOBout's Avatar
Member
iTrader: (2)
 
Join Date: Nov 2008
Location: Canada
Posts: 234
Looks good, I need these... I'm never sure if I've got 4x4, sometimes they lock... Other times I'm stuck haha.

Sean
Reply With Quote
  #14  
Old 09-24-2009
camodown's Avatar
Lost in Nowhere
iTrader: (3)
 
Join Date: Feb 2007
Location: Midland, TX
Posts: 5,029
that'll do, that'll do
Reply With Quote
  #15  
Old 09-24-2009
JRacer's Avatar
Member
iTrader: (2)
 
Join Date: May 2008
Location: Watson, Louisiana
Posts: 1,085
manual hubs doesn't mean its always gunna work. for instance my third time out with mine, they slipped and ive had nothing but trouble locking them since then. somehow water got through the o rings and, welcome to PITA!!!! Grease the HELL out of them. better safe than sorry like me.
Reply With Quote
  #16  
Old 09-24-2009
rideabikenick's Avatar
Member
iTrader: (4)
 
Join Date: Dec 2006
Location: Deltona, Fl.
Posts: 3,486
sweet
Reply With Quote
  #17  
Old 09-24-2009
RangerNVS's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2005
Location: Temple, TX
Posts: 1,341
that's your problem.....NO GREASE.....grease it what gums them up, especially when you get dirt/mud in them. I dunked mine in 30w motor oil and that's it. I haven't had any problems with them at all.
Reply With Quote
  #18  
Old 09-24-2009
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
yeah you dont want too much grease if any, doesnt let them slide into place.
Reply With Quote
  #19  
Old 09-24-2009
brianjwilson's Avatar
Member
 
Join Date: Nov 2006
Location: Hillsboro, Oregon
Posts: 3,650
I think the instructions even say specifically not to grease them.
Reply With Quote
  #20  
Old 09-25-2009
RangerNVS's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2005
Location: Temple, TX
Posts: 1,341
Brian correct, the instructions that I got said "NO GREASE" and said to use 30w motor oil....I'll have to scan it and post it up...I think that's the culprit that everyone is having. They are packing them full of grease and then wondering why they won't lock or unlock when they get muddy....NO GREASE PEOPLE!!!! LOL
Reply With Quote
  #21  
Old 09-25-2009
camodown's Avatar
Lost in Nowhere
iTrader: (3)
 
Join Date: Feb 2007
Location: Midland, TX
Posts: 5,029
well we don't have to worry about yours getting muddy, haha
Reply With Quote
  #22  
Old 09-25-2009
RangerNVS's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2005
Location: Temple, TX
Posts: 1,341
boy that's calling the kettle black Casey.....your just as bad as matt who can't make it to Altus....so there
Reply With Quote
  #23  
Old 09-25-2009
camodown's Avatar
Lost in Nowhere
iTrader: (3)
 
Join Date: Feb 2007
Location: Midland, TX
Posts: 5,029
haha altus shmatlus.

I wish I could do something in the truck now a days. All it does is sit in the garage looking ugly, then the occasional trip to buffalo wild wings which is 5 blocks away
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How To: AVM Hub Install Version 2 Redneckstone Engine & Drivetrain 10 01-09-2014 02:05 PM
How To: AVM Hub Install Version 1 Biz Engine & Drivetrain 28 12-20-2008 11:51 PM
Avm Manual Hub Install Help!!! huggyjd Drivetrain Tech 10 03-22-2008 08:18 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:14 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.