My first 87 Ranger..340K..RIP - Ranger-Forums - The Ultimate Ford Ranger Resource


Snapshots Share photos of vehicles in this sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-29-2011
RangerXLT18's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: New York
Posts: 127
My first 87 Ranger..340K..RIP

this was my first truck when i was in HS..88 xlt 2.9l v6 5spd 2wd. picked it up for $125 from friend of a friend. the thing may look like hell but the thing sure did run good for how old it was and all the miles on it. i loved just beatin on the truck and hitting stuff with out a care in the world lol my dad has takin some parts off it as you can proly tell but lot of goodtimes with the truck..so figured id snap some pics for ol time sake and let you guys might get a kick out of it.
- mistake on my part not sure of the miles on the truck..proly around 150-2k

Name:  SDC10404.jpg
Views: 1
Size:  216.3 KB

Name:  SDC10405.jpg
Views: 1
Size:  162.8 KB

Name:  SDC10409.jpg
Views: 1
Size:  56.3 KB

Name:  SDC10410.jpg
Views: 2
Size:  186.8 KB

Last edited by RangerXLT18; 04-29-2011 at 03:25 PM.
Reply With Quote
  #2  
Old 04-29-2011
dbking321's Avatar
Member
iTrader: (1)
 
Join Date: Mar 2007
Location: Shippensburg/York PA
Posts: 636
how did it die?
Reply With Quote
  #3  
Old 04-29-2011
Member
 
Join Date: Apr 2011
Location: erie,pa
Posts: 99
Quote:
Originally Posted by dbking321 View Post
how did it die?
x2
Reply With Quote
  #4  
Old 04-29-2011
RazorsEDGE's Avatar
There's no lifeguard in the gene pool
iTrader: (4)
 
Join Date: Aug 2006
Location: New Mexico
Posts: 7,501
How do you know it has 340k on it?
Reply With Quote
  #5  
Old 04-29-2011
RangerXLT18's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: New York
Posts: 127
it didnt really die..just kinda took it off the road and bought a new truck. had endless problems im 99% sure the thing had that many miles on it. towards the end had to put bit of money into it,whole clutch assembly, new plugs, wires, distributor, etc to keep it running. the motor always missed never ran on all cylinders, stalled quite a bit. even wires to the starter fried or something happened to it that had to run own electrical to starter and get it running..was rotting out on the fire wall even, had to weld and fix it cuz the pedal assembly was gettin pushed thru, thing was such a rot box. im pretty sure it had that many miles..dont know why it wouldnt..look at the truck and how old it is..
Reply With Quote
  #6  
Old 04-29-2011
RazorsEDGE's Avatar
There's no lifeguard in the gene pool
iTrader: (4)
 
Join Date: Aug 2006
Location: New Mexico
Posts: 7,501
Well the odometer only reads 34k. There's no way you'd know its rolled over 3 times unless you've driven the truck since it was new.....
Reply With Quote
  #7  
Old 04-29-2011
RangerXLT18's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: New York
Posts: 127
Quote:
Originally Posted by RazorsEDGE View Post
Well the odometer only reads 34k. There's no way you'd know its rolled over 3 times unless you've driven the truck since it was new.....
how do you figure it only has 34k on it? there are 6 numbers. 340529..which would be 300k. or am i missing something?
Reply With Quote
  #8  
Old 04-29-2011
RazorsEDGE's Avatar
There's no lifeguard in the gene pool
iTrader: (4)
 
Join Date: Aug 2006
Location: New Mexico
Posts: 7,501
You are missing something. The white square at the end is the number after the decimal. 34052.9 miles is what it reads.
Reply With Quote
  #9  
Old 04-29-2011
RangerXLT18's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: New York
Posts: 127
Quote:
Originally Posted by RazorsEDGE View Post
You are missing something. The white square at the end is the number after the decimal. 34052.9 miles is what it reads.
hm didnt even relise that..so it only goes up to 99k and rolls around again..weird..thanks for clearing that up. ill fix it
Reply With Quote
  #10  
Old 04-29-2011
hurley's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2010
Location: West Belmar NJ
Posts: 1,488
What's with the gap in between the cab and bed. Looks a little off.
Reply With Quote
  #11  
Old 04-29-2011
RangerXLT18's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: New York
Posts: 127
Quote:
Originally Posted by hurley View Post
What's with the gap in between the cab and bed. Looks a little off.
cab mounts rotted out.
Reply With Quote
  #12  
Old 04-29-2011
Pless215's Avatar
Member
 
Join Date: Mar 2008
Location: Dewy Rose, GA
Posts: 473
My dad's has around 280k on it. Known the owner since it was new, and we're just waiting on it to roll over again
Reply With Quote
  #13  
Old 04-29-2011
Member
 
Join Date: Oct 2010
Location: aspers, PA
Posts: 801
my dad had one that had 25000 on it when he sold it, still ran like a champ
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
First Post, First Day, First Car. Sierra Invenio Member Introductions 8 05-12-2015 12:34 PM
RIP '95 Ford Ranger - Lost in the Black Forest Fire MichaelV General Ford Ranger Discussion 11 06-23-2013 08:02 PM
RIP Ranger 5/5/12 (Kind of pic heavy) 99DangerRanger General Ford Ranger Discussion 37 05-12-2012 12:03 AM
RIP Ford Ranger 3.0 V6 - no more in 2009 skateboard34 General Ford Ranger Discussion 111 11-27-2008 06:55 PM
RIP....first gen 4x4 TheStig88 Snapshots 5 11-23-2008 10:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:41 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.