1999 ford ranger 2.5 5 speed engine bogs down in 4 and 5 and makes noises - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-30-2012
Member
Thread Starter
 
Join Date: Jun 2012
Location: belton missouri
Posts: 3
1999 ford ranger 2.5 5 speed engine bogs down in 4 and 5 and makes noises

hello i have a 1999 ford ranger with 2.5 5 speed so first off i know its not the transmission since it has a completely new one in it with fly wheel and clutch ok here is what it's doing when i drive it feels like it has no power when i try to give it more gas to get speed it bogs down and the motor makes noises like when your too high in gear and not going fast enough i have done a tune up on it 3 part fuel system cleaning with new fuel filter new plugs and wires i have even replaced the iac twice now and it is still saying its bad check wires there fine it's getting to where it doesnt want to move at times and since has been over 100 outside this past week it really doesn't like it i have taken back to the transmission shop and they said its engine problems that they don't work on there the best transmission shop in town so i know i was not done bad by them so anyone else having this problem for the iac to keep saying its bad there would have to be a vacuum leak but i have looked and do not see one i have done the vacuum tests funny thing is if i let it set for a few days with out driving it drives better till it warms up more please help since i still own money on the lien of this truck lol
Reply With Quote
  #2  
Old 06-30-2012
Member
 
Join Date: Feb 2012
Location: Windsor, WI
Posts: 93
Quote:
Originally Posted by mwm1983 View Post
hello i have a 1999 ford ranger with 2.5 5 speed so first off i know its not the transmission since it has a completely new one in it with fly wheel and clutch ok here is what it's doing when i drive it feels like it has no power when i try to give it more gas to get speed it bogs down and the motor makes noises like when your too high in gear and not going fast enough i have done a tune up on it 3 part fuel system cleaning with new fuel filter new plugs and wires i have even replaced the iac twice now and it is still saying its bad check wires there fine it's getting to where it doesnt want to move at times and since has been over 100 outside this past week it really doesn't like it i have taken back to the transmission shop and they said its engine problems that they don't work on there the best transmission shop in town so i know i was not done bad by them so anyone else having this problem for the iac to keep saying its bad there would have to be a vacuum leak but i have looked and do not see one i have done the vacuum tests funny thing is if i let it set for a few days with out driving it drives better till it warms up more please help since i still own money on the lien of this truck lol
Sounds like a possible vapor lock situation, try hooking up a fuel pressure gauge and monitor the fuel pressure. How many miles on vehicle??? ANy codes??
Reply With Quote
  #3  
Old 06-30-2012
Member
Thread Starter
 
Join Date: Jun 2012
Location: belton missouri
Posts: 3
There is 134,520 miles on truck i will have to do that see if that is what causing it and the only code is for my iac idle air control valve that i have replaced twice now and i have check wires going to it there fine the only other way that code comes up is if there is a vacuum leak
Reply With Quote
  #4  
Old 06-30-2012
Member
 
Join Date: Feb 2012
Location: Windsor, WI
Posts: 93
Quote:
Originally Posted by mwm1983 View Post
There is 134,520 miles on truck i will have to do that see if that is what causing it and the only code is for my iac idle air control valve that i have replaced twice now and i have check wires going to it there fine the only other way that code comes up is if there is a vacuum leak
Have you disconnected the battery cable to reset the computor after installing IAC???

Have you tried a smoke test for vacuum leak?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ford Ranger V6 4.0 5 Speed Engine Bogs down dskkri1 4.0L OHV & SOHC V6 Tech 12 01-12-2015 12:34 PM
engine bogs down after trip joec3 SOHC - 2.3L & 2.5L Lima Engines 0 11-18-2013 03:55 PM
Ranger bogs down when I press the throttle finnskeezy 4.0L OHV & SOHC V6 Tech 2 02-22-2011 09:32 AM
Engine bogs down in mud?? rizoss16 General Ford Ranger Discussion 24 04-28-2009 10:36 AM
horn makes funny noises zabeard General Ford Ranger Discussion 19 08-24-2007 02:13 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:15 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.