2000 Ranger p0171 and p0455 (pending) - Ranger-Forums - The Ultimate Ford Ranger Resource

SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

2000 Ranger p0171 and p0455 (pending)

Reply

 
 
 
  #1  
Old 06-03-2014
Member
Thread Starter
Join Date: Jun 2014
Location: Concord, New Hampshire
Posts: 1
Icon4 2000 Ranger p0171 and p0455 (pending)

Hello,

I'm having an issue with my 2000 ford ranger.
The check engine light is on and it is currently throwing the p0171 code (bank 1 too lean).

It currently also has a p0455 code pending and it is difficult to fill at the gas station. In order to get the fuel in the tank I have to pump it very slow.

I just replaced the alternator and cleaned the MAF sensor while I was in there, I did notice some corrosion around the MAF sensor when I removed it from the intake.

It also seems to be idling strangely with the rpms continually going up and down.

Any help would be appreciated.
 
Reply With Quote
  #2  
Old 07-21-2014
Member
Join Date: Jul 2014
Location: Las Vegas
Posts: 2
I have been having this same issue on my 97 Ranger. I got code P0171 and code P0174. I disconnected the MAF sensor and it immediately ran perfect so I replaced it with a new one and it still idles like crap.
 
Reply With Quote
  #3  
Old 11-06-2014
Member
Join Date: Nov 2014
Location: Panama City
Posts: 1
P0171 bank too lean

Originally Posted by mikeyg6754 View Post
Hello,

I'm having an issue with my 2000 ford ranger.
The check engine light is on and it is currently throwing the p0171 code (bank 1 too lean).

It currently also has a p0455 code pending and it is difficult to fill at the gas station. In order to get the fuel in the tank I have to pump it very slow.

I just replaced the alternator and cleaned the MAF sensor while I was in there, I did notice some corrosion around the MAF sensor when I removed it from the intake.

It also seems to be idling strangely with the rpms continually going up and down.

Any help would be appreciated.
Replace the MAFS mine was doing same exact thing I cleaned it first and it rough idled. I replaced and she purrs! As far as 455 I have the same trouble and haven't figured it out yet. I may replace the charcoal canister on Saturday. I let u know what the outcome is.
 
Reply With Quote
  #4  
Old 05-11-2018
Member
Join Date: May 2018
Location: PERRIS
Posts: 4
FNG here

I have this exact problem on my 00 XLT. What is the outcome of this? I'm new but the post looks older, where do I find the final response? Thanks
 
Reply With Quote
  #5  
Old 05-11-2018
RF Veteran
iTrader: (1)
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 10,017
Originally Posted by GunnerP76 View Post
I have this exact problem on my 00 XLT. What is the outcome of this? I'm new but the post looks older, where do I find the final response? Thanks
Welcome to the forum

You should start your own thread
Include year, engine size and 2wd or 4x4, also manual or automatic might matter.
And any "running" issue symptoms, i.e. stalling, high idle, pinging noise, ect.............

Also specific codes, all of them, "me too" is not as helpful as specific codes

Single bank code like P0171 is different for 4cyl engine and V6/V8 engines, so engine size matters

P0455 was an EVAP code so doesn't effect engine operation
 
Reply With Quote
  #6  
Old 05-14-2018
Member
Join Date: May 2018
Location: PERRIS
Posts: 4
Thanks Ron

Originally Posted by RonD View Post
Welcome to the forum

You should start your own thread
Include year, engine size and 2wd or 4x4, also manual or automatic might matter.
And any "running" issue symptoms, i.e. stalling, high idle, pinging noise, ect.............

Also specific codes, all of them, "me too" is not as helpful as specific codes

Single bank code like P0171 is different for 4cyl engine and V6/V8 engines, so engine size matters

P0455 was an EVAP code so doesn't effect engine operation
Thanks I will do so. I'm new to this forums and haven't figured it out yet. I'm sure it will come to me, lol.
 
Reply With Quote
  #7  
Old 05-15-2018
RF Veteran
iTrader: (1)
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 10,017
Just go to General Discussions area: https://www.ranger-forums.com/genera...discussion-15/

And Click on NEW THREAD, just above where the posts are listed
Put in a TITLE, like Getting P0171 code
Then list what Ranger you have, i.e. 2002 4.0l automatic Ranger...............
And the codes you are getting
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
j99ranger4x4
4.0L OHV & SOHC V6 Tech
0
06-16-2013 10:57 AM
j99ranger4x4
4.0L OHV & SOHC V6 Tech
7
07-20-2011 09:55 PM
9ranger8
1" & 3" Body Lifts
3
04-01-2011 08:38 AM
winks
General Ford Ranger Discussion
27
06-25-2010 06:31 AM
rngprerunner
General Ford Ranger Discussion
5
06-30-2008 08:06 AM


Thread Tools
Search this Thread