Ignition Issues... - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-07-2011
Member
Thread Starter
 
Join Date: Aug 2011
Location: Farmersburg, IN
Posts: 3
Ignition Issues...

Hey guys.

Been working on the truck, the coil pack that controls the passenger side spark plugs will come and go. It does not put out any spark, but once I start driving, it'll work, stop, work, stop... It's quite frustrating.

Checked the firing order, and it's correct. I've changed my plugs, plug wires, and the coil pack to see if any of those were the culprits...So far, no justice.

The plug that goes to the coil pack, I'm wondering if it's bad or has a break in the wiring that I should track down and repair.

Anything else I should check?

Thanks everyone!
-Trey B.
Reply With Quote
  #2  
Old 08-07-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
What engine/year?
Reply With Quote
  #3  
Old 08-07-2011
Member
Thread Starter
 
Join Date: Aug 2011
Location: Farmersburg, IN
Posts: 3
Quote:
Originally Posted by StxDangerRanger View Post
What engine/year?
I'm dumb for not posting that to begin with.

2.3L 4-banger.
1994.
Reply With Quote
  #4  
Old 08-07-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
I can't remember if that truck has a lower part to the coil pack, when you took the coil pack off, the thing you unplugged it from. that may be bad.
Reply With Quote
  #5  
Old 08-07-2011
Member
Thread Starter
 
Join Date: Aug 2011
Location: Farmersburg, IN
Posts: 3
Thanks for the suggestion. I'm working all day today, and have the next 2 days off. So I'm going to do some diagnostics. It goes through a harness, so I'm not sure where the next hop from the coil pack is. I planned on checking it out though.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Gauge issues/heating issues/high oil pressure Fw87 General Ford Ranger Discussion 2 04-26-2015 12:08 AM
Ignition issues ZENITH676L SOHC - 2.3L & 2.5L Lima Engines 0 07-14-2010 09:07 PM
JBA Ignition wires. Mboever General Technical & Electrical 8 05-18-2006 06:16 AM
msd 6a ignition 02rangeroffroad 4.0L OHV & SOHC V6 Tech 6 10-19-2005 07:58 PM
ignition wires/plugs afi_pilot85 4.0L OHV & SOHC V6 Tech 3 03-26-2005 05:31 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:52 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.