Odometer quit working on 97 - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-17-2006
Member
Thread Starter
 
Join Date: May 2006
Location: Honolulu, HI
Posts: 3
Odometer quit working on 97

Hi Guys,

I have a 97 ranger standard cab 2.3L w/5spd. My odometer just stopped working. I have replaced the speed sensor on the transmission but that didn't help. Speedometer works fine but odo and trip odo not working.
Sometimes the trip odo will roll real slow.

Any suggestions would be great before I spend more money on parts.
Reply With Quote
  #2  
Old 09-17-2006
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
If the speedometer works, that means that the VSS is OK and its wiring must be OK all the way to the speedometer. Your problem is in the odometer mechanism itself.
Reply With Quote
  #3  
Old 09-17-2006
dixieranger44
Unregistered User
 
Posts: n/a
same thing happened with my 96. it starts workin once in a while though
Reply With Quote
  #4  
Old 09-17-2006
Member
Thread Starter
 
Join Date: May 2006
Location: Honolulu, HI
Posts: 3
I just took the whole thing apart, (gage cluster), and found that the gear on the motor that turns the odo had fallen apart. I will try to get a new gear from the dealer.
Reply With Quote
  #5  
Old 09-17-2006
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Quote:
Originally Posted by dreamison
I just took the whole thing apart, (gage cluster), and found that the gear on the motor that turns the odo had fallen apart. I will try to get a new gear from the dealer.
My guess is that the gear is 'not serviced separately', meaning that you cannot buy it from the dealer except as part of a new speedometer assembly. $$$

I'd try a junkyard.
Reply With Quote
  #6  
Old 09-18-2006
Member
iTrader: (1)
 
Join Date: May 2006
Location: Portage, IN
Posts: 350
Quote:
Originally Posted by rwenzing
My guess is that the gear is 'not serviced separately', meaning that you cannot buy it from the dealer except as part of a new speedometer assembly. $$$

I'd try a junkyard.
If you don't find anything at the jy, I still have my non-tach cluster from before the swap. I'd be willing to send you the entire motor/gear assembly.
Reply With Quote
  #7  
Old 09-18-2006
Master Urza's Avatar
Member
 
Join Date: Aug 2006
Location: Redlands, CA/San Luis Obispo, CA
Posts: 234
You know what that means? Your engine will last forever. No new miles on it no matter where you drive. You have the perfect machine.
Reply With Quote
  #8  
Old 09-26-2006
Member
Thread Starter
 
Join Date: May 2006
Location: Honolulu, HI
Posts: 3
Hey guys, I was able to get one from a yard. I'm rackin up the mile once again.

Thanks for the help...
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
odometer quit working lsf53 General Technical & Electrical 8 12-16-2010 08:55 PM
odometer quit working lsf53 General Technical & Electrical 8 11-10-2010 01:56 PM
OHC Quit Working mossyoak1992 General Technical & Electrical 13 07-08-2009 12:11 PM
Radio, OHC and Power Windows quit working. GSUhooligan General Technical & Electrical 3 04-27-2009 11:00 AM
Odometer Quit working PhilpotHunter General Technical & Electrical 4 06-07-2005 02:30 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:15 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.