need help diagnosing a clunk - Ranger-Forums - The Ultimate Ford Ranger Resource


Suspension Tech General discussion of suspension for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-13-2010
Member
Thread Starter
 
Join Date: Jan 2010
Location: cranston,ri
Posts: 108
need help diagnosing a clunk

i have a 99 xlt 3.0 flex fuel 2wd. when i go over a bump i get a clunk on the front passenger side. i know people say check some bushings but i dont know witch ones or were they are. pics or advice would be very much appreciated. im not a mechanic but i am learning quick.

thanks
aaron
Reply With Quote
  #2  
Old 09-14-2010
0ranger99's Avatar
Member
 
Join Date: May 2010
Location: woonsocket RI
Posts: 224
This is a 4x4 but the bushings placement shouldn’t change look at these you’re looking for gaps between the sway bar and the bushing also check the end links they could be broken and just plain worn out

Also look at these the upper contol arm bushings and upper and lower shock mount bushings

this should help but sometimes it just takes time to find a bushing thats starting to ware out
good luck
Reply With Quote
  #3  
Old 09-14-2010
lumpy4000's Avatar
Member
 
Join Date: Aug 2009
Location: Orillia, Ontario
Posts: 379
if anything, i say ball joints!!!! look at the first picture, bottom circle and to the right.... thats the ball joint on the LCA (lower control arm). those need regular greasing and tend to fail. also the uppers do fail, but not as common as the lowers.... prop the vehicle up and put a jack stand under the lca, with the weight on the jack stand, see if you have any play that you wouldnt expect.... also check the wheel nuts..... and last but not least the wheel bearing.
Reply With Quote
  #4  
Old 09-14-2010
Member
Thread Starter
 
Join Date: Jan 2010
Location: cranston,ri
Posts: 108
thanks man i think that helped i think it might be a tierod. my outer right one has a torn boot i think it might be hitting the other side
Reply With Quote
  #5  
Old 09-15-2010
Member
Thread Starter
 
Join Date: Jan 2010
Location: cranston,ri
Posts: 108
it ended up being a broken shock mount haha
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need advice diagnosing starting problem dvdtlsn General Technical & Electrical 2 12-23-2014 09:07 AM
I need help diagnosing 2.3 problems jerry44 DOHC - 2.3L Duratec / Mazda L Engines 4 10-25-2014 08:07 PM
Help Diagnosing a Thumping Sound in Driveline Glenn Goodrich Drivetrain Tech 5 01-31-2010 02:54 PM
Need help diagnosing problem David N 4.0L OHV & SOHC V6 Tech 4 08-25-2009 03:16 PM
Weird problem I need help diagnosing IcecreamLtDan General Technical & Electrical 7 03-06-2008 04:01 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:05 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.